WordPress.org

Ready to get started?Download WordPress

Forums

SEO Title Tag
[resolved] Upgrade database bug (4 posts)

  1. RoBorg
    Member
    Posted 9 months ago #

    Hi,

    I just upgraded the plugin and the database doesn't seem to have upgraded properly.

    Before the upgrade, I didn't have any "description" columns in the table - the upgrade didn't add them but requires them to be there.

    There also seems to be a bug in seo-title-tag-3.4.php; line 96 says:
    CHANGE description title VARCHAR(255) NOT NULL,
    instead of
    CHANGE description description VARCHAR(255) NOT NULL,

    Workaround
    Run these queries on your database (replace wp_ with the appropriate prefix)

    ALTER TABLEwp_seo_title_tag_categoryADDdescription` VARCHAR( 255 ) NOT NULL
    ALTER TABLE wp_seo_title_tag_tag ADD description VARCHAR( 255 ) NOT NULL
    ALTER TABLE wp_seo_title_tag_url ADD description VARCHAR( 255 ) NOT NULL`

    http://wordpress.org/extend/plugins/seo-title-tag/

  2. Robert
    Member
    Posted 9 months ago #

    Thank you, but the plugin doesn't save any data.

  3. RoBorg
    Member
    Posted 9 months ago #

    Well all the tables are empty, but that doesn't stop it spewing out errors. My Apache error log is full of this kind of thing:

    2013-07-01 01:43:36 - Error: WordPress database error Unknown column 2013-07-01 01:43:36 - Error: WordPress database error Unknown column 'description' in 'field list' for query SELECT title, description from wp_seo_title_tag_category where category_id = 305 made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/redacted/archive.php'), get_header, locate_template, load_template, require_once('/themes/redacted/header.php'), wp_head, do_action('wp_head'), call_user_func_array, WPSEOTitleTag->outputMetaTag

    If it doesn't store any data, why does it create tables and read from them on every page hit?!

  4. Stephan Spencer
    Member
    Plugin Author

    Posted 9 months ago #

    Thanks for bringing this to our attention. The issue has been fixed. All that is required to do now is deactivate than activate the plugin.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.