WordPress.org

Ready to get started?Download WordPress

Forums

upgrade automatically generates contentless page (4 posts)

  1. htmljenn
    Member
    Posted 3 years ago #

    I have used the "upgrade automatically" feature in the past without issue, but for the last few version updates (3.0.3 and 3.0.4 for sure) I click on it, fill in my password, and am given a contentless page.

    The page has the standard WordPress navigation (Dashboard, etc.) and the notification that I should upgrade to 3.0.4. But there is nothing else there.

    When I view the source for the page, it's invalid - in fact there is nothing below <div class='update-nag'>WordPress 3.0.4 is available! Please update now.</div>

    This happens in both upgrading WordPress and plugins. Which is annoying. :-)

    I know I can upgrade manually - that's what I do to solve this. But it would be nice if the automatic upgrade were working again.

  2. Emil Uzelac
    Theme Review Admin
    Posted 3 years ago #

    Plugins are the most common cause of WordPress problems, this is especially when it comes to new upgrades just like in your case.

    Best thing to solve this issue is to deactivate all plugins and check

    a) all of them are up to date.
    b) each and every single plugin is compatible with the version of WordPress you're using.

    If the plugin isn't compatible do a little plugin research and locate similar one.

    I've seen many times before where inactive plugin can cause issues, so if there are some that you don't need, delete them.

    To rule "bad" plugins once you did all this, activate one by one and see what's happening.

    I manage 43 WordPress sites at the moment and none of the had any problems with the upgrade or any other major issues like that.

    Many plugin developers always go an extra mile and test their plugins with the upcoming WordPress releases, however there bunch of plugins without any updates for months even years, so you have to be extra careful with any choice of plugins.

    Cheers,
    Emil

  3. htmljenn
    Member
    Posted 3 years ago #

    Thanks for the great suggestion. Unfortunately, this site has no plugins installed. :-( Turning them off usually my first step. Sorry, I forgot to mention that.

    I suspect I'm going to have to export the entries, save the media, and delete the whole site and do a clean install. Ugh.

  4. Emil Uzelac
    Theme Review Admin
    Posted 3 years ago #

    Sorry to hear that :( Good Luck!

Topic Closed

This topic has been closed to new replies.

About this Topic