WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] upgrade 2.9.2 to 3.0 problem: can't login to site admin (12 posts)

  1. pwachira
    Member
    Posted 4 years ago #

    Hi,

    I upgrade from 2.9.2 to 3.0 by using automatic upgrade.
    There is no warning message, no database error and I can access my website. But when I try to login to site admin it always redirect to "http://.../wp-admin/upgrade.php?_wp_http_referer=/wp/wp-admin/"

    So I can't login at all. Do you have any suggestion?

    Regards
    Wp

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Try:
    - switching to the default theme by renaming your current theme's folder using FTP (or use whatever file management application your host provides)

    - resetting the plugins folder by FTP or phpMyAdmin.

    - re-running the upgrade manually.

  3. pwachira
    Member
    Posted 4 years ago #

    I followed your instruction but it didn't work at all.

  4. answerblip
    Member
    Posted 4 years ago #

    Im having the same issue.

    No Upgrade Required

    Your WordPress database is already up-to-date!

    When I click continue is just takes me to my home page and not to my Dashboard.

  5. esmi
    Forum Moderator
    Posted 4 years ago #

    Try:
    - switching to the default theme by renaming your current theme's folder using FTP (or use whatever file management application your host provides)

    - resetting the plugins folder by FTP or phpMyAdmin.

    - reviewing http://wordpress.org/support/topic/411649

  6. wildebeest
    Member
    Posted 4 years ago #

    I have the same issue - no site after "upgrade"

    Plugins have been reset to a:0:{} and reviewing the link above gives me nothing I can use to resolve this. the autoupdater said that it had completed successfully, yet when I try to log in I get this.

    Error message I receive

    Server error!

    The server encountered an internal error and was unable to complete your request.

    Error message:
    Premature end of script headers: index.php

    If you think this is a server error, please contact the webmaster.
    Error 500

    Any thoughts would be appreciated.

  7. DannyWRP
    Member
    Posted 4 years ago #

    I'm having the same problem as above. After upgrade, all I get is a blank page.

    Before I even upgraded, I changed it to the default theme, backed-up the DB, and disabled all the plug-ins. The installation appeared to work, until I clicked on something. From then on, all I got was a blank screen with a completely blank page source.

    I then downloaded the new v.3.0 installation files, installed them per instruction, but when I went to run upgrade.php, it just immediately went to a blank screen.

    I am really stuck now as it should have worked fine.

  8. ashsmh
    Member
    Posted 4 years ago #

    Hi,

    I too have the same problem. Can't log in with my admin username and password. When I try, I get an error message.

  9. DannyWRP
    Member
    Posted 4 years ago #

    Okay, I have verified my option_value field is at a:0:{}. I grabbed the new v.3.0 zip file again, and uploaded it via FTP as per the instructions. I renamed my old plugins file and uploaded the new one that came in the zip file. I made sure any old cache info was removed.

    I then ran "upgrade.php" and it just stayed as a blank white page! I am really at a loss here. I have as virgin an upgrade as can possibly be done, and nothing. My worry now is that the upgrade screwed something up in my DB tables.

    If anyone has any new ideas I can try, I am all ears ;)

  10. DannyWRP
    Member
    Posted 4 years ago #

    YAY! I resolved my problem. After doing everything I mentioned in my previous posts I noticed that in my /wp-content/ directory I still had 2 old files associated with caching; advanced-cache.php and wp-cache-config.php. I removed them both, and now everything is working just fine.

    It's always the little things...

  11. pwachira
    Member
    Posted 4 years ago #

    Hi,

    I also resolved my problem. I'm using memcached plugin so get_option('db_version') return a cached value. After I restarted memcached daemon, the problem gone. :)

  12. dsniece
    Member
    Posted 4 years ago #

    Hi,

    I did not resolve the problem exactly but found a workaround to get to the dashboard. First I log in on the login page, then I get to the page telling me "No Update Required" and it sends me to the actual site skipping the dashboard. But I noticed that the site indicated I was indeed logged in. On the Contact Us page of my theme, I noticed and "edit" link in the corner. Clicking this took me to the control panel. The same trick worked with some the the theme-generated links.

    Now that I have access to the dashboard, I will be able to find a true solution.

Topic Closed

This topic has been closed to new replies.

About this Topic