WordPress.org

Ready to get started?Download WordPress

Forums

Upgrade 2.1 to 2.1.3 -- most pages now 404 (4 posts)

  1. Tom Parker
    Member
    Posted 6 years ago #

    I upgraded to the latest release and tried to carefully follow all the steps, but I've apparently failed. I've left all plugins deactivated and switched to the default theme as I try to troubleshoot this. The site is:

    MotoBrief

    While the home page will load and the admin pages seem fine, any other page -- archives, the About page, single post page -- all seem to be not found. Any idea what I did wrong? I deleted all the WP files/folders except those specified and ran upgrade.php after uploading the new files. Any help?

  2. Tom Lany
    Member
    Posted 6 years ago #

    Looks like a database issue.

    Do you have backups? If you do not, you may want to contact your host ASAP to see if they have backups of your site in its old condition. Most hosts write over them with new backups soon - so you may have to act fast.

    I don't know specifically how to help, but you could try rolling the site back to how it look before based on the backup copies.

  3. Chris_K
    Member
    Posted 6 years ago #

    All seems to be working now. Did you visit Options -> Permalinks and recreate your .htaccess file?

  4. Tom Parker
    Member
    Posted 6 years ago #

    I did not visit the Permalinks page and didn't realize it affected the .htaccess file. That was a step I overlooked. Hopefully this resolves all the issues -- I'll verify later and confirm.

    For my edification -- any thoughts on why this happened and how it corrected itself?

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags