WordPress.org

Ready to get started?Download WordPress

Forums

UpdraftPlus Backup and Restoration for WordPress
[resolved] Updraft-Dropbox (19 posts)

  1. rickvv
    Member
    Posted 9 months ago #

    This is a weird one.
    With the latest UpdraftPlus, and Dropbox...WP ver 3.7.1, Thesis theme ver 1.8.5. Hosting account on BlueHost. This is an add-on domain, not a subdomain, though.
    I've setup UD as a plugin, and authenticated to DBox, it says it's authenticated, and I see correct user name and quota at my Dropbox in the upper bar of the plugin.
    The backup runs (gives me a warning about Big Files, but OK...), and gets a success alert at the end.
    But trying this with two different DropBox accounts, the backup set never gets to Dropbox!
    I had tried it after disabling all plugins (but didn't set Theme to any of the defaults).
    I've installed it on three other domains last night (all settings the same, even same host, but different Dropbox accounts. I even had it running on my Dropbox, until I got the account owner's dropbox login and changed from mine to their dropbox).
    This one on ricksbees.com hasn't worked yet.
    (Files are placed in the updraft folder inside public_html/subaccount dir , just not out to Dropbox).
    Here's the latest log on pastebin, http://pastebin.com/pHmsnAbc
    Thanks so much for any ideas!!
    Rick
    (have spent several hours on this)

    http://wordpress.org/plugins/updraftplus/

  2. David Anderson
    Member
    Plugin Author

    Posted 9 months ago #

    Hi Rick,

    The only time I've come across before, the problem was that the website owner's PC wasn't syncing with their Dropbox correctly. When they went to view their Dropbox directly, at https://www.dropbox.com, the backup was there.

    David

  3. rickvv
    Member
    Posted 9 months ago #

    Thanks, David,
    But that's the funny thing ... Logging in out on Dropbox.com shows me the Apps folder and the up drafts folder inside Apps, but the backup files aren't in there. (But you're right, they're not in the sync folder on the PC, either ;)
    I'll try a wipeout and uninstall plugin, use WordPress twenty-twelve theme, and try it again.
    It worked so well on three other website domains, that I can't quite see through this one!
    (Debug only warns me of really big files while it's working on a zip...)
    I'll let you know what we get.

    Thought...is the pro version different enough to be worth buying and trying?
    Rick

  4. David Anderson
    Member
    Plugin Author

    Posted 9 months ago #

    Hi Rick,

    I was rushing out before - I've read the log file now. It doesn't look like it's managing to get access to Dropbox at all.

    Do you have the PHP curl module installed? Go to the 'expert' section of the UD settings; then click on the 'php info' link. Is there then a section headed 'curl' in the window that opens up? If yes, then what version number is showing for curl?

    Best wishes,
    David

  5. David Anderson
    Member
    Plugin Author

    Posted 9 months ago #

    Oops - I overlooked the opportunity to advertise the wares that make the whole operation possible!

    The Premium version is equal to the free version, plus support and all the add-ons that are listed on this page: http://updraftplus.com/shop/ (with more to come in future).

    David

  6. rickvv
    Member
    Posted 9 months ago #

    Yes, curl enabled.
    (copy/paste from phpinfo)
    libcurl/7.24.0 OpenSSL/1.0.0 zlib/1.2.3 c-ares/1.7.0 libidn/1.18 libssh2/1.2.2

    I may have to look at the Premium!
    Thanks.
    ANd BTW, I just installed it and ran it on another domain in my BlueHost account...the main domain.(thetechwiz.net)
    And, I installed and ran the backup using MSIE 10 (Win7), and the job worked. I'll try MS Int Expl with the other domain (ricksbees.com)

  7. rickvv
    Member
    Posted 9 months ago #

    It looks like it's maybe just this domain (ricksbees.com) that is giving me trouble.
    Latest logfile here:
    http://pastebin.com/tLESEDiQ

    Thanks,
    rick

  8. David Anderson
    Member
    Plugin Author

    Posted 9 months ago #

    That logfile is showing the same problem.

    Does the Dropbox authentication procedure work normally? If you click the authentication link again from the Dropbox settings section, then what happens?

    I think it's very likely to be something odd in the web server's setup, since it's something wrong with the HTTP communication with Dropbox, and this is the only time I've seen something like this specific pattern (and Dropbox is the most popular option) - it'd likely be worth asking the web hosting company for advice.

    David

  9. rickvv
    Member
    Posted 9 months ago #

    Hi David-
    Yes, the authentication seems to be OK.
    I set the settings, and pick dropbox.
    Save.
    Go back up, click authenticate with dropbox.
    Dropbox.com opens in browser, asking for permission and 'only have access inside Apps folder...' I log in.
    Back at UpDraft, I get "You appear to be authenticated".
    And sometimes the banner at top of Settings page shows "Success" and my name, % of dropbox total, etc.
    (SOMETIMES not...) Problem?
    Funny thing is that ricksbees.com (problem domain) and thetechwiz.net (Updraft works) are both on the same server, in the same set of domain folders...
    I'll check with them. I guess. :(
    Thanks,
    rick

  10. rickvv
    Member
    Posted 9 months ago #

    One more thing.
    In UD phpinfo, I get php version 5.2.17
    But in the php config on the server cPanel, I have 5.4/single.
    Something doesn't look right here.
    Next step.
    THanks.

  11. David Anderson
    Member
    Plugin Author

    Posted 9 months ago #

    And sometimes the banner at top of Settings page shows "Success" and my name, % of dropbox total, etc.
    (SOMETIMES not...) Problem?

    It should only show when you authenticate, and then not on new subsequent visits.

    If your CPanel shows something different, then you could ask your hosting company about why that is.

    David

  12. rickvv
    Member
    Posted 9 months ago #

    OK, now I understand the occasional banner visibility.
    I thought this might have been the problem.

    I'll check with host on the PHPinfo discrepancy.
    Thanks very much. I'll let you know what I find.
    (keeping in mind, that the UD works on one domain in my account, but not this one. And the PHP settings apply to all domains/subs/addons in the account.)
    Have a good weekend!
    -rick

  13. David Anderson
    Member
    Plugin Author

    Posted 9 months ago #

    Hi Rick,

    If the setup is otherwise identical to a working site, then try de-activating all your other plugins, switching to a default theme, and then re-trying the backup. Perhaps another plugin is interfering.

    David

  14. rickvv
    Member
    Posted 9 months ago #

    Done. All plugins except UP+, default theme 'twenty-ten'.
    UD had been uninstalled, so we re-installed it with above settings.
    Changed settings, saved, then authenticated to dropbox.
    Ran back, database only.
    Got success, as well as success email. But no Dropbox. :(
    (Also. This morning, I setup UD on another 'addon' domain...like current problem domain...and the new addon domain backed up as expected, and sent to dropbox)
    Here's log from problem domain.
    http://pastebin.com/dY3bdXc1

    Oh. And when I reinstalled, the status page noted that we had 2 sets available. THese backups are going into the server directory, it seems. Just not to dropbox. (I may have to try google drive next time, but that looks tricky)

  15. rickvv
    Member
    Posted 9 months ago #

    Google Drive backup is working.
    I'll leave it at that for this domain, and use Dropbox for my other domains.
    (Seriously looking at buying the Developer option of your system.)
    Thanks for your help!
    rickvv

  16. rickvv
    Member
    Posted 9 months ago #

    This is a longish logfile, but it may reveal something that the Dropbox logs don't.
    http://pastebin.com/tSPtxpP8
    thanks

  17. David Anderson
    Member
    Plugin Author

    Posted 9 months ago #

    Hi Rick,

    Glad that's working at last! The Google Drive log is all normal - i.e. what you'd hope/expect for.

    Very strange. I had one last suggestion, but your log file rules that out too. Oh, one more - perhaps you have a .htaccess or php.ini file that disables some PHP functions? I've seen that once before.

    Finally... this has uncovered that no warning/error is being raised that's obvious for the user, even though the backup is known not to have been sent to Dropbox. I've fixed that in the next release (due out next week). (I won't rush out a fix now, as after 370,000 downloads this is the first time I've seen this pattern!).

    David

  18. rickvv
    Member
    Posted 8 months ago #

    Hi David, No reply needed here.
    Just to update you that I did buy the Developer option this week, and while all my sites have updated just fine so far, this installation on the problem site...is still not going to Dropbox (logfile looks about the same).
    Google Drive upload is fine, so I'm leaving this one there for now.
    Have a good week,thanks,
    rick

  19. David Anderson
    Member
    Plugin Author

    Posted 8 months ago #

    Hi Rick,

    Thanks for letting me know. If you're happy with it backing up to Google Drive, then let's leave it. If you want me to take a closer look, then send the login details to contact@updraftplus.com (WordPress and FTP, and I'll see what I can find).

    Best wishes,
    David

Reply

You must log in to post.

About this Plugin

About this Topic