WordPress.org

Ready to get started?Download WordPress

Forums

Updrade from a very old version of WP (4 posts)

  1. ztog
    Member
    Posted 5 years ago #

    Please don't beat me up too hard for this question. I haven't used my blog much over the past couple years, but am going to ramp up as I build my online business. I am still using version 1.5.2. Is it safe to upgrade to the newest version, 2.7? Or do I have some major rework to do? I didn't upgrade a couple times way back when due to problems and then just didn't blog that much anymore.

    The blog site works fine for me, but I hate to be so 'behind the times'. http://blog.magnetwizzard.com is where I am.

    Any help is muchly appreciated. I'm hosted on Apache servers, etc.

    Phyllis Barber
    ztog@ztog.com

  2. MichaelH
    Member
    Posted 5 years ago #

    Or do I have some major rework to do?

    Depends on your themes and plugins. If you get a new theme from http://wordpress.org/extend/themes it will be easier.

    1.Backup files.
    2.Backup database.
    3.Read WordPress Backups to make sure you did Steps 1 and 2
    4.Disable plugins
    5.Upgrade to 2.1
    6.Upgrade to 2.3
    7.Upgrade to 2.5
    8.Upgrade to 2.7.1
    9.Get new versions of plugins

    http://codex.wordpress.org/Plugins/Plugin_Compatibility
    http://codex.wordpress.org/Themes/Theme_Compatibility

    Oh, and go sit in the corner for not upgrading routinely ;)

  3. ztog
    Member
    Posted 5 years ago #

    Thank you very much for the help! And the corner is getting lonely, but I have hockey to keep me company....What I think I am going to do is just do lots of backups, and then start a new blog at the current level with a new theme and all the good stuff I can find to play with. I'm much more knowledgeable now about blogs than I was all those years ago. :)

  4. Milan Dinić
    Member
    Posted 5 years ago #

    5.Upgrade to 2.1
    6.Upgrade to 2.3
    7.Upgrade to 2.5
    8.Upgrade to 2.7.1

    On one installation I upgraded directly from 2.3 to 2.7 without problems so I think that 2.5 can be skipped (note that this is only my expirience, there might appear some problems).

Topic Closed

This topic has been closed to new replies.

About this Topic