WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Updgrade from 2.6 to 2.62 Permalink Problem (2 posts)

  1. CMedia
    Member
    Posted 5 years ago #

    Hi I have just upgraded from 2.6 to 2.6.2 and I can not get my user defined permalinks to work.

    I am getting a 404 screen error.

    If I set the permalinks to deault I can accessmy pages BUT I need to restore my user defined Permalinks ASAP

    Any suggestions as to what the problem is and how to fix?

    I have a number of plug-ins including Recent cimments Similar comments by Rob Marsh, SJ.

    Not sure about the .htaccess file and how that works

    Thanks in advance

  2. CMedia
    Member
    Posted 5 years ago #

    Hi After a lot of stuffing around and mileading leadsI finly got it to work

    The blog was on a IE6 server which does not support .htaccessfiles. If you have an installation on an IE6 server remove the .htaccess file.

    The solution is very simple.

    Create a file name "wp-404-handler.php" andcopy it to teh same directory whereyou installed the wp-config.php or index.php file 8This should be your root directory

    Inside the wp-handeler.php copy the following php code

    <?php
    $qs = $_SERVER['QUERY_STRING'];
    $_SERVER['REQUEST_URI'] = substr($qs, strpos($qs, ':80')+3);
    $_SERVER['PATH_INFO'] = $_SERVER['REQUEST_URI'];
    include('index.php');
    ?>

    You then need to set you site to look at this file when there is a 404 error

    THANKS TO Satchelmouth's Web log

    and Google Search IE6 WordPress permalink

Topic Closed

This topic has been closed to new replies.

About this Topic