WordPress.org

Ready to get started?Download WordPress

Forums

Updatred to Wp 2.9 and get this error - Warning: curl_setopt() [function.curl-se (29 posts)

  1. copypress
    Member
    Posted 4 years ago #

    hi

    i update to v 2.9 and i get this error - help me

    error message:

    Warning: curl_setopt() [function.curl-setopt]: CURLPROTO_FILE cannot be activated when in safe_mode or an open_basedir is set in /home/jon/public_html/wp-includes/http.php on line 1302

    please help me. thnx

    jon

  2. takuhii
    Member
    Posted 4 years ago #

    I'm getting the same problem too. I have no idea what it means, but I'd really like to fix it...

  3. takuhii
    Member
    Posted 4 years ago #

    I deactivated all my plugins and restarted them one by one, to try and find the fault, unfortunately I managed to restart them all without encountering the fault again. I thought it might have been the Twitter plugin, but nothing has kicked the fault off now.

    try deactivating ALL your plugins then re-activating them

  4. copypress
    Member
    Posted 4 years ago #

    i localized the plugin. its Cforms II v11.1 plugin used to make forms. I have it deactivated but don't knw how to get through. my host says safe mode is off so i guess its upto cforms to help me.

    But i wud like to knw what has changed in wordpress 2.9 that all of a sudden i am facing this error of curl_setopt()

    any help wud be great

    thnx
    jon

  5. tlebrun
    Member
    Posted 4 years ago #

    I too am getting the same error on both of my installs. Looking for a resolution...

    - T

  6. Ricardo
    Member
    Posted 4 years ago #

    The same problem here... I found here something about it... They say it solves itself in a few minutes. Good luck!

  7. phuongly.net
    Member
    Posted 4 years ago #

    I'm getting the same problem too. I have no idea what it means, but I'd really like to fix it...

  8. tlebrun
    Member
    Posted 4 years ago #

    I emailed my host and they disabled openbase_dir protection for my account. Shortly after emailing them I went to sleep, so I don't know if the error cleared with or without that fix on their end (per @Richard Hernandez's comments). As of now I don't have the problem.

  9. zakshow
    Member
    Posted 4 years ago #

    same problem here, what is the solution?

  10. jonradio
    Member
    Posted 4 years ago #

    Based on the lack of response to this post on the cforms forum, I'd say we are all going to have to wait for the plug-in developer to address the issue:
    http://www.deliciousdays.com/cforms-forum/troubleshooting/help-wordpress-29-and-curl_setopt-error/

  11. jonradio
    Member
    Posted 4 years ago #

    Or perhaps not. I just upgraded the Test system I have that uses cforms and it works fine, with just a couple of warnings at the bottom of the page:
    Warning: Unknown: open(/tmp/sess_18c8a7ce414ca40692a34cfcd9ef8515, O_RDWR) failed: Permission denied (13) in Unknown on line 0

    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0

    WordPress 2.9, cformsii 11.1 and Firefox 3.5.5

  12. eric.fournier
    Member
    Posted 4 years ago #

    I noticed this error on the dashboard and here's how I fixed it. I'm sure a bug needs to be submitted and the core updated but for what it's worth if you need this fixed now do the following:

    Edit /wp-includes/http.php and change the if statement on line 1300 to this:

    if ( defined( 'CURLOPT_TIMEOUT_MS' ) ) {
    			// EDF - The option doesn't work with safe mode or when open_basedir is set. More
    			// research is probably necessary however this seems to fix the problems I was
    			// seeing in the "WordPress Development Blog" section of the Dashboard.
    			if ( !ini_get('safe_mode') && !ini_get('open_basedir') ) {
    				$timeout_ms = (int) ceil( 1000 * $r['timeout'] );
    				curl_setopt( $handle, CURLOPT_CONNECTTIMEOUT_MS, $timeout_ms );
    				curl_setopt( $handle, CURLOPT_TIMEOUT_MS, $timeout_ms );
    			}
    		} else {
    			$timeout = (int) ceil( $r['timeout'] );
    			curl_setopt( $handle, CURLOPT_CONNECTTIMEOUT, $timeout );
    			curl_setopt( $handle, CURLOPT_TIMEOUT, $timeout );
    		}

    Hope it helps.

  13. zakshow
    Member
    Posted 4 years ago #

    The problem is from the XML Google sitemap, that's why when you want to publish or update a post you get that error message, because after updating or publishing, the plugin is called to rebuild the sitemap automatically.. I disabled the plugin and things got back to normal.. Try it and let me know..

  14. zakshow
    Member
    Posted 4 years ago #

    or just uncheck the options that make the sitemap get updated automatically after the blog content is edited..

  15. copypress
    Member
    Posted 4 years ago #

    @eric.fournier: thnx. it worked like a charm :P i hope we get a new official fix on this asap. #ericwin #wordpress2point9fail

  16. illustrata
    Member
    Posted 4 years ago #

    I don't have the XML Google sitemap plug-in but do have cforms...

    Revised the code as recommended by eric.fournier above and voilà, the problem disappeared.

    Thank you, Eric.

  17. arifabdull
    Member
    Posted 4 years ago #

    Dear everyone,
    Having the same problem just after upgrade to WP 2.9

    To fix it, you just need to modify the script as pointed out by eric.fournier

    Edit /wp-includes/http.php and change the if statement on line 1300 to this:

    if ( defined( 'CURLOPT_TIMEOUT_MS' ) ) {
    // EDF - The option doesn't work with safe mode or when open_basedir is set. More
    // research is probably necessary however this seems to fix the problems I was
    // seeing in the "WordPress Development Blog" section of the Dashboard.
    if ( !ini_get('safe_mode') && !ini_get('open_basedir') ) {
    $timeout_ms = (int) ceil( 1000 * $r['timeout'] );
    curl_setopt( $handle, CURLOPT_CONNECTTIMEOUT_MS, $timeout_ms );
    curl_setopt( $handle, CURLOPT_TIMEOUT_MS, $timeout_ms );
    }
    } else {
    $timeout = (int) ceil( $r['timeout'] );
    curl_setopt( $handle, CURLOPT_CONNECTTIMEOUT, $timeout );
    curl_setopt( $handle, CURLOPT_TIMEOUT, $timeout );
    }

    The only problem now is, I have to modify the said code one-by-one, manually for each websites which I am currently handling with.

    Anyway, thank you very much for sharing the way how to resolve this matter.

    http://www.arifabdull.com

  18. takuhii
    Member
    Posted 4 years ago #

    An update has been released for people using Google XML Sitemaps. Hopefully that will fix it for those users of the plugin.

    I seem to get this intermittently now

  19. jonradio
    Member
    Posted 4 years ago #

    I just re-cloned my Test System from my Production system, did an upgrade to 2.9, and the "Failed to write session data" warnings disappeared, without any sign of the curl errors. Admittedly, I don't use the XML Google sitemap plug-in, but I do use cforms.

  20. on4ya
    Member
    Posted 4 years ago #

    The problem is from the XML Google sitemap, that's why when you want to publish or update a post you get that error message, because after updating or publishing, the plugin is called to rebuild the sitemap automatically.. I disabled the plugin and things got back to normal.. Try it and let me know..

    @ Zakshow.

    Thanks for your advice. I disabled the XML Google sitemap and all works fine again.

    Robert

  21. Denis de Bernardy
    Member
    Posted 4 years ago #

  22. xanderrem
    Member
    Posted 4 years ago #

    The problem at my site with this error is the GD Simple Widgets plugin.

  23. Umbrovskis.com
    Member
    Posted 4 years ago #

    FYI:
    Even after changing code of http.php and Google sitemap update, error is still there.

  24. userword
    Member
    Posted 4 years ago #

    WordPress Development Blog Configure
    Warning: curl_setopt() [function.curl-setopt]: CURLPROTO_FILE cannot be activated when in safe_mode or an open_basedir is set in /home/putocomc/public_html/some.com/wp-includes/http.php on line 1302
    
    Warning: curl_setopt() [function.curl-setopt]: CURLPROTO_FILE cannot be activated when in safe_mode or an open_basedir is set in /home/putocomc/public_html/some.com/wp-includes/http.php on line 1303
    
    WordPress 2.9, oh so fine 19, December, 2009
    I want to make you mine, all the time… oh wait. Hello. I’m here on behalf of the entire WordPress development team and community to announce the immediate availability of WordPress version 2.9 “Carmen” named in honor of magical jazz vocalist Carmen McRae (whom we’ve added to our Last.fm WP release station). You can upgrade [...] […]
    2010: A Theme Odyssey 18, December, 2009
    After the video from the core team meetup was posted, the topic that seemed to get the most attention on Twitter and various community sites was Matt’s announcement that there would be a new default theme in 2010, so I thought I’d start with that as the first of the meetup summaries. When Kubrick was bundled [...] […]

    another one, it is a clean install with no plugin added just a theme. definitely there is an error or at least unexpected problem with wordpress 2.9 i expect wordpress team to read this and tell us about the importance of it.

  25. Denis de Bernardy
    Member
    Posted 4 years ago #

    @userword: see my above comment. It's one of three known WP 2.9 bugs, which are addressed in the coming 2.9.1.

  26. DianeWarth
    Member
    Posted 4 years ago #

    When I encountered the curl issue after upgrading to 2.9 I overwrote both php files (default-widgets and http) with their 2.86 versions and all's been well.

    Should I leave it be or upload the 2.9 versions and the patches?

  27. userword
    Member
    Posted 4 years ago #

    @userword: see my above comment. It's one of three known WP 2.9 bugs, which are addressed in the coming 2.9.1.

    i thought you were guessing not that you were sure about it. Nice to hear that they will fix it in next release.

  28. MnHotRod
    Member
    Posted 4 years ago #

    @eric.fournier: thanks for the tip. worked slick. i am a virgin to wp with my first install today. saw the error codes and panicked. all good now. going to load a graph paper press theme next. cheers, steve.

  29. corifeanu
    Member
    Posted 4 years ago #

    Just do it yourself or ask your provider to change the following settings in php.ini file where your website is running:
    open_basedir off
    safe_mode off

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags