WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Updating WordPress/Adding Plugins (9 posts)

  1. tnmccask
    Member
    Posted 1 year ago #

    It has been a while since I have last used WordPress and it has changed. Previously I could automatically update WordPress by clicking a link at the top of the page. I could also search for and add plugins and widgets to add to my site. Now, I cannot automatically update WordPress and I cannot search for or even view current plugins that I have installed on my site. How can I change this? How can I update WordPress and see the plugins and widgets that I have added to my site?

    Thanks!!!

  2. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    This should not normally occur, unless you are not an admin anymore.

    That said, in the main dashboard, look at upper right 'Screen Settings' and also the left sidebar can be collapsed, there is an arrow at the bottom, click it.

    Without a site link and with the info provided, we will be hard pressed to add more...

  3. tnmccask
    Member
    Posted 1 year ago #

    I am the admin. I have been the only one to have access to my wordpress account. How can I change it so that I am the admin again? I have tried clicking the arrow to open the menu on the left side, but it still does not show the plugins and everything else. I have also tried "Screen Settings"

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Using Phpmyadmin (or another MySQL management tool), first backup your database. Then navigate to your wp_usermeta table and locate the meta_key called "wp_capabilities" for your user_id. Change the meta-value for this record to:

    a:1:{s:13:"administrator";s:1:"1";}

  5. tnmccask
    Member
    Posted 1 year ago #

    Thanks for your response Esmi, but that is like foreign to me. lol! Is there a more simpler way to do this?

    Thanks again for your help!

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    Not if you do not have a working admin login - which you do not appear to have.

  7. tnmccask
    Member
    Posted 1 year ago #

    Ok. I'll try those directions above and see if it works.

  8. tnmccask
    Member
    Posted 1 year ago #

    Nope. That did not work. The WP_Capabilities is already set to
    a:1:{s:13:"administrator";s:1:"1";}

    Any other suggestions?

  9. tnmccask
    Member
    Posted 1 year ago #

    Never mind. I had a separate login that I forgot about for the admin.

    Thanks anyway!!

Topic Closed

This topic has been closed to new replies.

About this Topic