WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Updating to W3TC 0.9.2.8 causes Firefox @font-face issue with CDN (7 posts)

  1. Erik Ford
    Member
    Posted 1 year ago #

    After updating the plugin to the latest version, Firefox has stopped loading my custom webfont from Rackspace CDN altogether. No settings have been changed with the update and this was not an issue in previous versions of the plugin.

    Is anyone else experiencing the same thing? I have since had to temporarily disable the plugin until a fix can be found.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. unick69
    Member
    Posted 1 year ago #

    have you checked if your minify files are uploading to your CDN ???

    that might be your problem and if it is you are not alone ... check this thread
    http://wordpress.org/support/topic/0926%E2%80%938-wont-transfer-minifed-files-to-cdn?replies=5

  3. Erik Ford
    Member
    Posted 1 year ago #

    Yup. The minify files are uploading to my CDN which makes this issue even more baffling and frustrating.

  4. Daniel J. Lewis
    Member
    Posted 1 year ago #

    Actually, I don't think this is a 9.2.5–8 issue. I had this problem before the December 2012 update.

    It seems very unreliable when webfonts would work or not. Even when I could verify that the font files were uploaded to the CDN and internal "CDN-ized" paths were still correct. There was just something that Firefox wouldn't like about trying to load webfonts from my Cloud Files CDN.

    This isn't a new problem.

    My workaround in 0.9.2.8 is to add the webfont CSS files to the minify exclusions so they remain local while everything else is minified and uploaded to CDN.

  5. Erik Ford
    Member
    Posted 1 year ago #

    Thanks. I really would hate to add another HTTP request just for Firefox but will keep your solution top of mind if there are no better solutions.

  6. Daniel J. Lewis
    Member
    Posted 1 year ago #

    Before the December update (or sometime around recently), I had to play with minifcation order in manual mode. It'd seem like I would get it, but something with Firefox and W3TC was unreliable and it would seem like there was a caching problem with changes not being reflected (I completely disabled the browser's caching with a plugin).

    The best I could figure out was that the webfont CSS files had to be at the top of the minification, and one had to be over the other.

    My two webfonts were a custom font from Icomoon and a font I created with FontSquirrel's engine. Are you using either of those?

    But until some bigger issues are resolved (like why 0.9.2.8 is actually slowing down my site), I have disabled the plugin.

  7. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    The two latest version of the plugin adds origin header to the .htaccess files. Check them and if they exist.

    <FilesMatch "\.(ttf|otf|woff)$">
    <IfModule mod_headers.c>
            Header set Access-Control-Allow-Origin "*"
    </IfModule>
    </FilesMatch>

    Learn more: http://www.fontspring.com/support/troubleshooting/webfonts-are-not-loading-in-firefox

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic