WordPress.org

Ready to get started?Download WordPress

Forums

Updating 1.5 Plugin to 2.0: How to? (4 posts)

  1. Dondi
    Member
    Posted 8 years ago #

    Hello, I am new to WordPress and I am extremely impressed. I don't know what took me so long to check it out. Well, I did and became a fan immediately. I'm still learning my way around and have searched for hours looking for a guide for updating WordPress version 1.5 plugins to be compatible with version 2.0. Is there such a guide? Any pointers are greatly appreciated. Thx,

    Dondi.

  2. James
    Happiness Engineer
    Posted 8 years ago #

    Most v1.5 plugins should be compatible with WordPress. This list is being constantly updated with the latest in plugin compatibility reports. If you do find that a certain plugin is not compatible with WordPress v2.0, it is recommended that you contact the plugin's developer and ask them to upgrade it.

  3. Dondi
    Member
    Posted 8 years ago #

    Thanks macmanx. I already checked the compatibility list *and* emailed the plug-in author inquiring about an update for 2.0. However, neither has been fruitful.

    I would like to use the plug-in in question (Spreadshop) as the basis of a plugin that I would like to create. That's why I was inquiring about changes to update plugins from version 1.5 to 2.0.

    So, is there a summary somewhere that outline the required changes? Or, do I have to learn 1.5 and 2.0 plugin standards and figure out the differences myself? I can't believe that the latter is the case as what I'm asking for is fairly common release-to-release documentation for serious systems such as WordPress. Thx,

    Dondi.

  4. Dondi
    Member
    Posted 8 years ago #

    Please disregard my prior comment -- I figured out that the source of the error I encountered was an extra space after the '?>' token so the error had nothing to do with version 2.0.

    Thanks,

    Donovan.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags