WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Updated W3Cache and now very slow (23 posts)

  1. Flaneurblog
    Member
    Posted 1 year ago #

    Hi,

    The site in question is flaneur.me.uk. It was working fine, but I saw that W3 cache needed updating because of a security risk. I did this and now the site is very slow. 29s to load according to pingdom.

    Any ideas what to change to get the speed back? The settings that make w3cache work are:

    page cache - disk basic
    database - disc
    object - disc
    browser - enable
    cloudfare enable

    minify isn't happy, but it wasn't before.

    Thanks.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Karthik26
    Member
    Posted 1 year ago #

    Yaa.. Latest version of this plugin Slow Down My Website.. Now i removed It! :(

  3. ptnplanet
    Member
    Posted 1 year ago #

    The latest version contains a critical Bug that came with the latest plugin security update.

    Cache files now get the string <?php /* appended on cache write, so that the files' contents can't be displayed by simply viewing them in the browser.

    The plugin's authors simply fail to take the offset into consideration when reading cache files. This results in failed deserialization of the files' contents and cache misses on every cache read.

    If you want to look into the issue, it is located in the File /wp-contents/plugins/w3-total-cache/lib/W3/Cache/File.php in Line 279. Note that the expire value is read from the first four bytes of the file. Since the update the first four bytes are just "<?ph".

    You can either wait for a fix by the authors or fix it yourself by adding @fseek($fp, strlen("<?php /* ")); to Line 279 before $expires = @fread($fp, 4);.

    If you decide to add the mentioned changes, please note, that you do this at your own risk. I recommend switching from file/disc based caching engines to other available engines. Or wait until the issue is resolved.

    I have already notified the plugin's author and still waiting for a response.

  4. cretzzzu3000
    Member
    Posted 1 year ago #

    Happened to me too.

    It started producing a lot of files too(+3gb very fast).

    Removed it.

    P.S: be careful after deleting. If you can't see your images anymore change your permalink structure.

  5. yekxmerr
    Member
    Posted 1 year ago #

    Same here.
    If i had 2 websites on my vps i think i could crash the server rack lol. It only gives me problems when i log to the administration and ff i stay out of it the site is ok. When i need to post or do anything in the administration i deactivate the plugin (sometimes it isn't an easy task).
    Waiting for a fix.

  6. snurk
    Member
    Posted 1 year ago #

    Happened to me too, without any cache site loads in 1.2 seconds, with W3TC activated it loads in 5-10 seconds and cpanel tells me my site consumes up to 2 gb of ram memory .....

    My site went down from 29:th of december, coinciding with the new version of W3TC.. Waiting for a fix.

  7. kato
    Member
    Posted 1 year ago #

    It took me a long time to find the solution. It may seem obvious to some, but still I'll post it for those waiting indefinitely for an update:

    v.0.9.2.4

  8. jumbo
    Member
    Posted 1 year ago #

    kato, the plugin author retrofitted v0.9.2.5 changes into the older v0.9.2.4 archive, so anyone trying to downgrade won't actually be downgrading--they'll just be reinstalling v0.9.2.5 rebadged as v0.9.2.4

  9. CelsiusAnderson
    Member
    Posted 1 year ago #

    Same thing happen to my site too...Its really slow now after updated to v0.9.2.5

  10. pestwave
    Member
    Posted 1 year ago #

    Same problems here: http://www.shejipi.com

    Seems the wp-includes/ files can't be severd from my CDN, even if I have set them to be done so.

    Looking forward to the fix.

  11. kato
    Member
    Posted 1 year ago #

    Jumbo, 0.9.2.3 then?

  12. jumbo
    Member
    Posted 1 year ago #

    kato, yes, it looks like the 0.9.2.3 archive was left untouched, but that's a pretty steep downgrade. I did a file comparison between the two and the differences are quite significant.

  13. Petri Kainulainen
    Member
    Posted 1 year ago #

    I have several problems with the 0.9.2.5 version of this plugin and performance of the admin section was one of them. However, when I disabled both database and object caches, this problem disappeared. Of course if you need to use these caches, this will not solve your problem. Might be worth to try though.

  14. sLa NGjI's
    Member
    Posted 1 year ago #

    0.9.2.3 is one of real alternative, for more problems, but for my personal opinion the best is old developmental release 0.9.2.5b 2011-08-31 ;)

  15. nhowarth
    Member
    Posted 1 year ago #

    I had this 'very slow loading' problem as well using APC for caching Page, Minify, Database and Object - and Cloudflare CDN.

    Load times more than 6 secs reported by Pingdom.

    Fortunately I had an 'old' copy of v0.9.2.4 hanging around and have reverted.

    Everything is back as it was - website loading in under 2 seconds. Hopefully as the security bug seems to only affect database caching to disk, I'll be OK.

  16. jeebus13
    Member
    Posted 1 year ago #

    Same issue here... took me a while to figure this was it... what a frustrating day. 30 seconds or more for page load times.

    I've deactivated the plugin and the site is much better now. I know the plugin did help with the speeds on previous versions so hope the update fixes it.

  17. Awebus
    Member
    Posted 1 year ago #

    Same here. According to my host, it scans 20k+ files under w3c plugin directory for EACH request.

  18. wp-fan
    Member
    Posted 1 year ago #

    I think your issue has been tackled in this repaired version by wmiles. I use it on my installation, works like a charm, even precache loading has been fixed and enhanced by this author!!

  19. fromdebttohope
    Member
    Posted 1 year ago #

    This doesn't seem to have ever really improved my sites and not it seems to be noticeably slower since the update.

    I'm not a coder and not planning to be. I don't have time for that. It looks like i'm going to try out wp supercache and a few addins that were recommended.

    I saw the link above but I don't know who the source is so trying out someone else's fix isn't safe enough for me to risk it.

    Goodbye w3.

  20. wp-fan
    Member
    Posted 1 year ago #

    I have started a new thread about wmiles fixed version here. Experiences by users so far have been excellent.

  21. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    If you re-download 0.9.2.5 you'll find the issue is gone. If you're not following the installation instructions and are simply enabling all types of caching without running any tests to see if they help or trying to use caching types not recommend for your hosting account you will obviously not see improved performance. If you have questions please ask via a bug submission form as that support channel is easier for me to support than forums.

  22. ptnplanet
    Member
    Posted 1 year ago #

    I tried sending you the bug report I posted here http://wordpress.org/support/topic/updated-w3cache-and-now-very-slow?replies=21#post-3710678 but was unable to find your bug report form.

    Instead I sent you a message over your contact form on your w3-edge website but have yet to receive a response.

  23. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    We use wufoo for our forms and I don't have anything in my spam box. The support tab of the plugin is most reliable, it's the red menu option in the admin bar or under the performance menu.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic