WordPress.org

Ready to get started?Download WordPress

Forums

Rotating Tweets (Twitter widget and shortcode)
[resolved] Updated version of Rotating Tweets that uses the Twitter v 1.1 API (31 posts)

  1. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    Hi all,

    I've just updated Rotating Tweets to start using version 1.1 of the Twitter API.

    This is because Twitter are switching off the old version 1.0 of the API at some point in March - at which point older versions of Rotating Tweets will stop updating.

    If you have any questions or want to discuss any aspect of the new version of the plug-in, please post comments to this post.

    Martin

    http://wordpress.org/extend/plugins/rotatingtweets/

  2. rankore
    Member
    Posted 1 year ago #

    As soon as I click save after adding all the api details (Twitter API Consumer Key etc) there is a 500 error. I then click on reload page and it goes to wordpress settings page and has not saved the key input.

  3. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    Ah. That doesn't sound good.

    I've uploaded a new development version. Does that fix the problem?

    Martin

  4. mitch247
    Member
    Posted 1 year ago #

    Thanks for a great plugin... I am having issues with the new changes. I tried your development version and the error messages went away, however I still get the error:

    Problem retrieving data from Twitter
    Please check the Twitter name used in the settings.

  5. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    If you look at the HTML source for the page with Rotating Tweets on it, there should be a message immediately after the opening div (which is something like <div class='rotatingtweets' id='rotatingtweets_4000_scrollUp_512dbbb038a54'>).

    What does it say?

  6. mattkeowen
    Member
    Posted 1 year ago #

    I'm having similar issues once I enter the values in the following fields:

    Twitter API Access Token
    Twitter API Access Token Secret

    Let me know what I should do.

  7. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    Matt,

    Which error are you getting? The 500 error? Or the 'Problem retrieving data from Twitter' error?

    If you look at the HTML source for the page with Rotating Tweets on it, there should be a message immediately after the opening div (which is something like <div class='rotatingtweets' id='rotatingtweets_4000_scrollUp_512dbbb038a54'>).

    What does it say?

  8. mattkeowen
    Member
    Posted 1 year ago #

    Every time I go to save the Setting page with the API Access Token and API Access Token Secret, I get an Unable to Load Page error message. When I reload, I get all the Settings for my entire site. The plug in no longer shows up in my site -- despite still being in the footer widgets -- so no div is evident.

  9. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    Crikey. Can you send me a link to your site? Does any other plug-in do this?

    Is there any extra information on the HTML of the 'Unable to Load Page' page?

    What version of WordPress, PHP and MySQL do you have?

    What happens if you set WP_DEBUG to true in the wp_config.php file?

    Martin

  10. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    And does this guide to WordPress errors help?

    And does it happen in other browsers?

    Martin

  11. mattkeowen
    Member
    Posted 1 year ago #

    Sure, here's the link. I'm on the latest rev of WP, PHP, etc.

  12. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    The page of all variables that you're getting is .../wp-admin/options.php which is the form handler for admin pages, but I've no idea why WordPress is breaking this way.

    Is there an error listed for rotatingtweets_api_error on that page?

    What happens if you comment out:

    $test = rotatingtweets_call_twitter_API('statuses/user_timeline',NULL,$options);

    (It's about line 540).

    Have you historically had problems with plug-ins that pull in data from other sites?

    Martin

  13. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    The new development version might address this. Please let me know if it works for you.

  14. g00glen00b
    Member
    Posted 1 year ago #

    I just updated to the latest version and it worked (before that it didn't). I think it's solved now.

  15. Zagerij
    Member
    Posted 1 year ago #

    Hi Martin,

    Thanks for your great plugin! I really like it.
    Till today it works fine, then I updated the plugin and now it isn't working anymore.

    In the widget I get the message 'Problem retrieving data from Twitter'.

    I understand it has something to do with the Twitter API.
    So I went to Twitter to create an application. I filled in all the Twitter Consumer and Twitter Access Token keys in the plugin preferences but it still doesn't work.

    I think I did something wrong when I created he Twitter application. To be honest I don't have any idea what I have to fill in by the application details. Name, description, webiste, access level, request uri? Can you please help me to get your plugin working again.

    Thanks.

  16. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    Hi zagerij. Sorry it isn't working for you.

    When you go to wp-admin/options-general.php?page=rotatingtweets and click 'Save Changes' what message do you get at the top of the page?

    Which version were you using before?

    Martin

  17. Zagerij
    Member
    Posted 1 year ago #

    When I save it says: Instellingen opgeslagen (=Settings saved).
    Before I used version 1.3.10.

  18. n3ur0
    Member
    Posted 1 year ago #

    Dear Martin:
    Thank you for this plugin. I have been using it for a while and have been working nice. Just one question:
    I have been using it for showing tweets from other people. However, with the new API, I don't know if I could do this. Should the API be created by the twitter account I want to show?
    Thanks in advance.

  19. peabodyva
    Member
    Posted 1 year ago #

    Martin,
    I just updated to 1.3.12 and receive the 'Problem Retreiving Tweets'.
    I checked the HTML source to find:
    <!-- Error: 34 - Sorry, that page does not exist -->

  20. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    n3ur0

    It should fine with the new API. It will bring in tweets from all addresses.

    Martin

  21. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    PeabodyVA

    What happens when you try to save the settings on the /wp-admin/options-general.php?page=rotatingtweets page? What message do you get at the top of the page?

    Martin

  22. sharpenedsticks
    Member
    Posted 1 year ago #

    Hi Martin,

    I just updated to 1.3.12 and now receive the 'Problem Retreiving Tweets' error.
    Was working just fine prior to today...
    What should I check for?

    Thanks

  23. sharpenedsticks
    Member
    Posted 1 year ago #

    Re-installed my Twitter API info and got the SETTINGS SAVED banner on top of the page indicating all was well.

  24. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    What Twitter Screen Name are you using?

  25. sharpenedsticks
    Member
    Posted 1 year ago #

    @SharpenedSticks

  26. peabodyva
    Member
    Posted 1 year ago #

    Martin,

    It seems to show a settings saved message as normal.

    As an additional note, I reset all my keys on the dev.twitter (Consumer and Access keys and secrets) and no improvement.

  27. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    What happens if you remove the '@' sign?

  28. sharpenedsticks
    Member
    Posted 1 year ago #

    That did it!

    Ah, the shifting sands of syntax...

    Many thanks,

    SS

  29. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    peabodyva

    The latest version has been further upgraded to tackle remaining problems.

    If it doesn't work, to get fuller diagnostics, go to wp-config.php and change WP_DEBUG to true. You should get some useful error messages in the HTML.

    Martin

  30. peabodyva
    Member
    Posted 1 year ago #

    Removing the @ solved it for me as well.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic