WordPress.org

Ready to get started?Download WordPress

Forums

Squelch Tabs and Accordions Shortcodes
[resolved] Updated today and now Navigation Fancy Dropdowns don't work (5 posts)

  1. lisa.burgess
    Member
    Posted 1 year ago #

    I just updated to Squelch 0.2.1 and now my navigation dropdowns won't work. As soon as I deactivate the plugin, they come right back.

    When the plugin is enabled and I hover over my dropdown menu, I get a javascript error on superfish.js

    It seems like something in this plugin is conflicting with the dropdown menu js file, superfish.js

    Please help.

    http://wordpress.org/extend/plugins/squelch-tabs-and-accordions-shortcodes/

  2. Matt Lowe
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Lisa,

    Have you tried rolling the version of jQuery back in the plugin as described on the project home page?

    http://squelchdesign.com/wordpress-plugin-squelch-tabs-accordions-shortcodes/#troubleshooting

    The latest version of the plugin is using jQuery 1.9.1 which other plugins in your installation might not be ready for. You can however safely roll back to 1.8.3 in the configuration panel.

  3. lisa.burgess
    Member
    Posted 1 year ago #

    Hello, I am not sure how to do this. I tried this.

    I opened the squelch-tabs-and-accordions-shortcodes/squelch-tabs-and-accordions.php file in WPress admin panel and changed the version from saying 1.9.1 to 1.8.3 and saved the file.

    I then activated the plugin, but still my dropdowns don't work. (As soon as I deactivate the plugin, the fancy dropdowns work again.)

    This is the error from Chrome Developer tools:

    Uncaught TypeError: Cannot read property 'msie' of undefined superfish.js:11
    sf.IE7fix superfish.js:11
    $.fn.extend.showSuperfishUl superfish.js:11
    over superfish.js:11
    w admin-bar.min.js:1
    (anonymous function)

    Thanks,
    Lisa

  4. Matt Lowe
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Lisa, there's no need to edit the plugin files.

    Please go to the configuration screen for the plugin (Appearance > Tabs and Accordions) and check the settings look right. If any of the settings don’t sound right, please try changing them to more appropriate values. You can try using a previous version of jQuery and/or jQuery UI. Try rolling back jQuery to 1.8.3 to see if that makes a difference.

  5. lisa.burgess
    Member
    Posted 1 year ago #

    Hi Matt,

    Thanks, that was it! I rolled back the jquery and works fine. All set.
    Lisa

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic