WordPress.org

Ready to get started?Download WordPress

Forums

Updated To 3.3 And Now Having Issues With Permalink Structure (27 posts)

  1. plawhorne
    Member
    Posted 2 years ago #

    I just updated to the new 3.3 today and now I'm having a problem with my post now coming up properly formatted. In fact it's all coming up as one big page instead of the post being separate the way they were prior to this update. They also seemed to have merged with my pages too. I have no clue what's happening!

    I am using prettylink pro on my site and was told to check the permalink structure on my site but I see that it is no longer me add a custom structure and every time that I attempt to save it as such, it revets back to "post name".

    Because of this issue the front page of my blog now looks distorted. I have disabled all of the plug ins and the issue still has not been resolved.

    Any suggestions?

    Thanks!

  2. esmi
    Forum Moderator
    Posted 2 years ago #

  3. plawhorne
    Member
    Posted 2 years ago #

    Hi Esmi. Tried removing all of the plugins and reloading them and changing the template. Did not move the folder b/c I was not having a problem with the admin area. Still no luck!

    When I tried to update the permalinks custom structure to /%postname%/, it won't take it and keeps going to /sample-post/.

    Not sure why but I think that may be my issue.

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  5. Rename the plugins folder to plugins-old

    Yes, we know it's a pain, but it's on the list there for a reason.

  6. plawhorne
    Member
    Posted 2 years ago #

    did everything but resetting the plugins. thought i did not need to since i could enter my admin area. will do now!

    stay tuned! ;o)

  7. plawhorne
    Member
    Posted 2 years ago #

    Just reset the plugins folder to plugins-old. the problem still is there. did not switch the theme b/c i have a custom theme. will that effect it?

    this is my site: pamlawhorne.com

  8. govpatel
    Member
    Posted 2 years ago #

    permalinks only rewrite urls it does distorted any content on pages or posts may be is the theme you using switch to default theme and see if you still have same problem

  9. plawhorne
    Member
    Posted 2 years ago #

    just asked if it would affect my theme if i switched since it's a custom theme. it's also running on thesis.

  10. govpatel
    Member
    Posted 2 years ago #

    No all your settings for theme stay intact when you switch themes

  11. plawhorne
    Member
    Posted 2 years ago #

    changed it out. the theme. it looks quite messy so not sure if that took or now. what's my next move?

    thank you all for helping me!

  12. govpatel
    Member
    Posted 2 years ago #

    can your switch back to your theme and check your custom menus if they set the way you had them.

  13. plawhorne
    Member
    Posted 2 years ago #

    no. that didn't work. the blog is still spread out and mixed in with some pages.

    not sure whats happening!

    where would i look for custom menu changes?

  14. govpatel
    Member
    Posted 2 years ago #

    You mean the top menu I see blog where is suppose to be.

    You can find Custom menus by clicking on Appearance>>>>>Menus

  15. plawhorne
    Member
    Posted 2 years ago #

    sorry. yeah i know where to find the menus for the top. i though it was something in the template. sorry about the confusion!

    the rest of the blog appears to be in tack except for the blog itself. that seems to include my blog post and pages and pages that are not public plus it's not formatted correctly.

  16. govpatel
    Member
    Posted 2 years ago #

    then looks like your theme index.php file your blog template is causing the problem you will need some one check it out has nothing to with permalinks

  17. plawhorne
    Member
    Posted 2 years ago #

    sigh... ok. thanks. do you know what i should have them look for?

    i really appreciate all of your help!

  18. govpatel
    Member
    Posted 2 years ago #

    did you have any plugin that you used to make your pages private

  19. plawhorne
    Member
    Posted 2 years ago #

    no. nothing that i can remember.

  20. govpatel
    Member
    Posted 2 years ago #

    I sorry to say until I know how you had your pages setup is hard to help you

  21. seanpatrick
    Member
    Posted 2 years ago #

    Plawhorne: pretty sure "Post name" is the exact same as what previously was only available withe custom structure of "/%postname%", thus is automatically switches to that because it no longer needs to be listed as a custom option.

    I'm having a different problem... some of my existing longer permalinks are being amended from "this-is-a-long-permalink-title" to "this-is...link-title" type permalinks. Anyone have an idea why those ellipsis are showing up and how to remove them? It's causing the permalinks to not load properly when linked automatically within the code.

    Thanks.

  22. smyleinn
    Member
    Posted 2 years ago #

    Try this in the permalink setting
    /index.php/%postname%/

    it worked for me.

  23. seanpatrick
    Member
    Posted 2 years ago #

    smyleinn: not sure if you were addressing my issue, but that didn't fix it.

    I took some screenshots of the problem with the system now inserting ellipsis into permalinks. See the linked images for an example. Any suggestions or fixes would be greatly appreciated.

    http://www.thenewlanguage.com/temp/badlink01.png

    http://www.thenewlanguage.com/temp/badlink02.png

  24. arrak
    Member
    Posted 2 years ago #

    smyleinn,
    I do need to thank you! That did fix the problem with my blog! Thanks a million grains of sand, sorry but thats all I have.

  25. smyleinn
    Member
    Posted 2 years ago #

    seanpatrick:
    Try this.
    Goto Dashboard. Then click on reinstall. It will not break anything further (I tried on two blogs).

    After this goto Settings --> Permalinks
    In the custom settings add /index.php/%postname%/

    Basically somehow, we have to have /index.php/ in front for permalinks to work. EG:
    /index.php/%year%/%postname%/
    /index.php/%year%/%month%/%postname%/
    and so on.

  26. smyleinn
    Member
    Posted 2 years ago #

    arrak:
    A sincere act of gratitude is much more than anything else in life. Thanks and god bless

  27. seanpatrick
    Member
    Posted 2 years ago #

    smyleinn: Tried that to no avail. Still seeing ellipsis in the permalinks, both on the edit panel and on the live site.

    Anyone else have any ideas? Seems like it only does it over a certain character count, but only started occurring after upgrading to 3.3.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic