WordPress.org

Ready to get started?Download WordPress

Forums

WP Slimstat
[resolved] Updated to 2.8.4 and still: Warning: stripos() expects parameter 1 (8 posts)

  1. thescarletfire
    Member
    Posted 1 year ago #

    Hello.

    I recently updated SlimStat to v2.8.4 and now see a message across the top of my WordPress website:

    Warning: stripos() expects parameter 1 to be string, array given in /home/admin/public_html/wp-content/plugins/wp-slimstat/wp-slimstat.php on line 68

    What does this mean, and how can I fix it please? I've restarted, cleared all caches, but don't understand why this new SlimStat update would cause this error. I have updated no other plugs recently.

    Thanks!

    http://wordpress.org/extend/plugins/wp-slimstat/

  2. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Hi there, as I said in my other reply to your request, please see if you can manually download and install version 2.8.4 again. I spotted the error when it was too late, and I was able to fix it only a few minutes later.

    Thanks,
    Camu

    PS: a vote for my plugin would be a nice way to say thank you!

  3. kevquirk
    Member
    Posted 1 year ago #

    Awesome, just had to re-install this plugin to fix the issue and all my stats from the last 3 months are gone. Thanks for that.

  4. thescarletfire
    Member
    Posted 1 year ago #

    SlimStat, being a stats plugin, would almost certainly retain data over time so a clean install would of course wipe all stored data.

    That's why I asked him (in another thread) about how to reinstall to preserve stored data (via FTP vs. WordPress Dash).

    I tried a manual overwrite/copy and paste, rather than a full out delete all-reinstall all - that would cause you to lose all data.

    Sorry you lost your stats.

  5. thescarletfire
    Member
    Posted 1 year ago #

    A fix is coming Monday the dev said.

  6. camu
    Member
    Plugin Author

    Posted 1 year ago #

    You should have come to the forum BEFORE doing that, my friend. You would have found out that there's a temporary workaround! Go the plugin's settings page and wherever you see the word ARRAY as one of the options' value, just delete it and save. It was as easy as that.

    Also, just disabling the plugin until a fix would have been released, could have avoided you to lose your stats. Yours wasn't a smart move, my friend.

    Plus I'm releasing a new version on Monday to fix the issue.

    You're welcome!

    Camu

    PS: people keep forgetting that all of this is done FOR FREE, and even though I try to not overlook things, sometimes mistakes happen, and all I can do is to fix them as soon as I can ;) You're free to use a different tool, if you are too disappointed by WP SlimStat. Sorry for venting...

  7. mikolajek
    Member
    Posted 1 year ago #

    This temporary fix works as a charm!

    Things happen, so I wouldn't bother too much, even though I got surprised seeing no visitors for the past 2 days ;)

  8. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Thank you for your feedback, it confirms what I suspected the problem was :)

    Best
    Camu

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.