WordPress.org

Ready to get started?Download WordPress

Forums

Thematic
Updated Thematic from 0.9.7.7 to 1.0.3.2.but problems with style of event list (14 posts)

  1. g60dave
    Member
    Posted 1 year ago #

    Hi All

    Ive taken on a task of looking after a charity's web site and keeping it updated etc. All plugins and WP is updated but when i update thematics from version 0.9.7.7 to 1.0.3.2 it changes the style of the listed events from being within boxes to no boxes. This is the same with the posts list we have under the news section. As i didnt design the child theme im not too sure where to start, but any advice would be great

    Thanks

  2. Gene
    Member
    Posted 1 year ago #

    Between 0.9.7.7 and 1.0.3.2 we made some changes to Thematic's default & @imported stylesheets. I'm thinking that its a style issue and less likely related to the markup. It sounds like you're missing a border to some element marking up the event content.

    You can find all of the past Thematic Versions here: http://themes.svn.wordpress.org/thematic/

    To recreate the styling without downgrading Thematic. You could test moving the older stylesheets from the 0.9.7.7 and @import them from the child theme directory.

    That would be how I'd start to tackle it; but without a link to the site or a link to the stylesheets your using, it's hard to see exactly whats going on between your content and your styles.

  3. g60dave
    Member
    Posted 1 year ago #

    Hi there, thanks for replying.
    Ive just tried copying all the CSS files from
    thematics\library\styles
    style.css

    from the 0.9.7.7 to the new versions

    but no luck

    http://childhoodfirst.delaweb.co.uk/get-involved/fundraising-events/
    is a backup using the new version

    http://childhoodfirst.org.uk/get-involved/fundraising-events/
    is the 0.9.7.7 version

  4. g60dave
    Member
    Posted 1 year ago #

    can i ask what you mean by

    To recreate the styling without downgrading Thematic. You could test moving the older stylesheets from the 0.9.7.7 and @import them from the child theme directory.

  5. g60dave
    Member
    Posted 1 year ago #

    i have just tried all the versions between 0.9.7.7. and the latest and whats interesting is every revision after 0.9.7.7 doesnt work with the error

    Fatal error: Call to undefined function thematic_canonical_url() in /wp-content/themes/mytheme/header-eventspage.php on line 25

    but the very latest at least loads but still the the original problem

  6. g60dave
    Member
    Posted 1 year ago #

    that line refers to thematic_canonical_url

  7. g60dave
    Member
    Posted 1 year ago #

    which i have removed now.

    Whcih kind of worked, i also worked out that the version 1.0 was ok, but 1.01 changed text - then there was no change till 1.0.2.1

    upgrade 1.0.3.1 messed with the boxes round posts. so im making progress

  8. g60dave
    Member
    Posted 1 year ago #

    scrap that, i think its down to the dynamic-classes.php file, but not too sure what yet

  9. Gene
    Member
    Posted 1 year ago #

    I looking at the two links above and I cannot discern the difference between the event two site's styling. Did you fix it? If not what exactly is the visual side effect.

  10. g60dave
    Member
    Posted 1 year ago #

    Hi there, have a look now at the 2 links now.

    I was trying to resolve the problem, and it is defiantly code located in wp-content/themes/thematic/library/extensions/dynamic-classes.php

    I have actually upgraded the whole thematic folder to 1.0.3.2 but have kept the dynamic-classes.php from 1.0.2.1 to keep it working on the main site, but im not sure which part of the code is wrong?

  11. g60dave
    Member
    Posted 1 year ago #

    also to add i did make a few small changes to my child theme such as removing thematic_canonical_url from my header.php

  12. Gene
    Member
    Posted 1 year ago #

    As far as the post loop styling for events goes, you're missing the .hentry class on the .postloop > #post-[ post-ID ].clearfix

    1.0.3.1 & 1.0.3.2 default to using the WordPress core body and post classes. To use the Thematic's original post and/or body classes moving forward use this code in your child theme's functions.php

    add_theme_support('thematic_legacy_body_class');
    add_theme_support('thematic_legacy_post_class');

    Look here for more info: http://thematictheme.com/blog/ Also the forums on that site are a good place to ask questions and find answers specific to Thematic.

    I hope this helps you fix your problem. If And when you find a resolution please mark this topic as "Resolved"

  13. g60dave
    Member
    Posted 1 year ago #

    Thanks ill give the forums over there a go!

    With regards to that code, would it go anywhere?

  14. Gene
    Member
    Posted 1 year ago #

    The code goes in the functions.php file in your child theme. If that file does not exist in the child theme directory, create it and add that code after a<?php opening tag.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic