WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Updated Plugin, FTP issues recurring (17 posts)

  1. bradtid
    Member
    Posted 1 year ago #

    Using Plesk, tried to manually change permissions, still asks for FTP information every time. Once I give it the FTP information, it gives me new errors. When I try to ignore them, the same message pops up when I go to the Plugins menu- EVERY TIME. No other big caching plugins besides SEO stuff and social media stuff.

    Error 1:

    Unfortunately we're not able to create folders and files or write to them to complete the installation for you automatically. Please enter FTP details below to complete the setup.

    /var/www/vhosts/XXXXXXXXX/httpdocs/new/wp-content/cache/config
    /var/www/vhosts/XXXXXXXXX/httpdocs/new/wp-content/cache/tmp
    Database caching will not function properly: /var/www/vhosts/XXXXXXXXX/httpdocs/new/wp-content/db.php is not latest version.
    Object caching will not function properly: /var/www/vhosts/XXXXXXXXX/httpdocs/new/wp-content/object-cache.php is not latest version.
    Page caching will not function properly: /var/www/vhosts/XXXXXXXXX/httpdocs/new/wp-content/advanced-cache.php is not latest version.
    Either the /var/www/vhosts/XXXXXXXXX/httpdocs/new/wp-content directory is not write-able or another caching plugin is installed.This error message will automatically disappear once the change is successfully made.

    Current process is run by (XXXXXXXXX) but owner of created files is (XXXXXXXXX). They should be the same. Talk with your host about this issue.

    If this is correct behavior then read WordPress Update Constants section in WordPress Codex with regards to FS_METHOD for possible solution. Defining it disables the check.

    /var/www/vhosts/XXXXXXXXX/httpdocs/new/wp-content is write-able. When finished installing the plugin, change the permissions back to the default: chmod 755 /var/www/vhosts/XXXXXXXXX/httpdocs/new/wp-content. Permissions are currently 0777.

    ERROR 2 (after putting in FTP information)

    W3 Total Cache Error: Could not change permissions 777 on /var/www/vhosts/XXXXXXXXX/httpdocs/new/wp-content back to original permissions 777.

    W3 Total Cache Error: Could not change permissions 777 on /var/www/vhosts/XXXXXXXXX/httpdocs/new/wp-content back to original permissions 777.

    /var/www/vhosts/XXXXXXXXX/httpdocs/new/wp-content is write-able. When finished installing the plugin, change the permissions back to the default: chmod 755 /var/www/vhosts/XXXXXXXXX/httpdocs/new/wp-content. Permissions are currently 0777.

    Halp!

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Mellco
    Member
    Posted 1 year ago #

    I have the same issues and more. I have uninstalled this latest version from 2 sites and will not upgrade the rest. Now I will have to wait till the devs sort this out.

    This upgrade was a fail for the two sites I upgraded. Better is the enemy of good.

  3. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    @bradtid, did you follow the instructions and recommendations in the error message?

  4. bradtid
    Member
    Posted 1 year ago #

    Yup- I entered the FTP information, ran the code- and that's what led me to Error #2. If I ignore Error #2, then go back to Plugins, then it shows me error #1 all over again. I've checked the CHMOD and it's 777 on the right area, and then when I switch it to 755, it gives me that error again.

  5. sdk
    Member
    Posted 1 year ago #

    having the same issue -- changing wp-content to 777 doesn't do anything:

    Unfortunately we're not able to create folders and files or write to them to complete the installation for you automatically. Please enter FTP details below to complete the setup. 
    
    /var/www/vhosts/xxxxxxxxxxxx.com/httpdocs/blog/wp-content/cache
    /var/www/vhosts/xxxxxxxxxxxx.com/httpdocs/blog/wp-content/cache/config
    /var/www/vhosts/xxxxxxxxxxxx.com/httpdocs/blog/wp-content/cache/tmp
    Database caching will not function properly: /var/www/vhosts/xxxxxxxxxxxx.com/httpdocs/blog/wp-content/db.php is not latest version.
    Object caching will not function properly: /var/www/vhosts/xxxxxxxxxxxx.com/httpdocs/blog/wp-content/object-cache.php is not latest version.
    Page caching will not function properly: /var/www/vhosts/xxxxxxxxxxxx.com/httpdocs/blog/wp-content/advanced-cache.php is not latest version.
    Either the /var/www/vhosts/xxxxxxxxxxxx.com/httpdocs/blog/wp-content directory is not write-able or another caching plugin is installed.This error message will automatically disappear once the change is successfully made.
    
    Current process is run by (10001:505) but owner of created files is (48:48). They should be the same. Talk with your host about this issue.
    
    If this is correct behavior then read WordPress Update Constants section in WordPress Codex with regards to FS_METHOD for possible solution. Defining it disables the check.
  6. ogalinski
    Member
    Posted 1 year ago #

    Have the same problem here. I created manually all the folders and copied the files, but still can't save settings; I'm getting:

    "W3 Total Cache Error: Default settings are in use. The configuration file could not be read or doesn't exist. Please (button) to create the file."

    Can't get past this.

  7. bradtid
    Member
    Posted 1 year ago #

    One thing I'm noticing is that it seems like both @SDK's and my WordPress installs are in subdirectories- XXXXXXXXX/httpdocs/new/wp-content etc and xxxxxxxxxxxx.com/httpdocs/blog/wp-content - this wouldn't have in impact, would it?

  8. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    The plugin uses WordPress FileSystem functionality to write to files. It checks if fileowner, fileownergroup of created files match process owner. If this is not the case it does not work. Can try adding define('FS_METHOD', 'direct') to wp-config.php this circument the checks.

  9. bradtid
    Member
    Posted 1 year ago #

    Aha! I did that- added
    define('FS_METHOD', 'direct'); to the wp-config.php file, and now most of the errors are gone!

    Now I only have one error left (which is kind of weird)-

    W3 Total Cache Error: Could not change permissions 777 on /var/www/vhosts/XXXXXXXXX/httpdocs/new/wp-content back to original permissions 777.

    Any ideas?

  10. jesseoverright
    Member
    Posted 1 year ago #

    also had same permissions error as sdk.
    Current process is run by (501:501) but owner of created files is (48:48). They should be the same. Talk with your host about this issue.
    rolled back to old version of wp cache for now.

  11. sdk
    Member
    Posted 1 year ago #

    define('FS_METHOD', 'direct'); worked

    just FTP and change permissions to 777 on wp-content, then refresh the w3 total cache page within WordPress... once the tasks have been completed remove the define('FS_METHOD', 'direct'); from your wp-config.php file and change wp-content back to 755 permissions

  12. bradtid
    Member
    Posted 1 year ago #

    Now I just have this error:

    W3 Total Cache Error: Could not change permissions 755 on /var/www/vhosts/XXXXXXXXX/httpdocs/new/wp-content back to original permissions 777

    Is that fine?

  13. geerthoekzema
    Member
    Posted 1 year ago #

    Same problems here, what i've tried so far:

    1. add define('FS_METHOD', 'direct');

    2. that worked for most of the errors, but i'm stille getting the
    W3 Total Cache Error: Could not change permissions 755 on /var/www/vhosts/XXXXXXXXX/httpdocs/new/wp-content back to original permissions 777

    3. I resetted the file ownership (via direct admin) of the wp-content folder

    4. any settings that I change are not saved. I'm trying to turn on the page caching. When I do so, it gives me the message that all changes are saved, but the page cache is still off.

    5. I'm also getting warnings that my wp-content folder should be 0755 or 0777 (depends on what the current chmod is).

    Same problems on other websites. As you stated in other post, I think it got something to do with the file-ownership. However, i'm only able to reset the file ownership. Which changes the ownership to my "user" and not to apache.

  14. geerthoekzema
    Member
    Posted 1 year ago #

    Ah well,
    I't almost working now.

    1. Deactivate the plugin
    2. Remove all files (cache + plugin)
    3. chmod /wp-content/ to 777
    4. re-install plugin
    5. activate plugin

    The problem is the file-ownership. Either the wp-content should be owned by apache, or the rights should be 777. But... also the cache files should be 777 or owned by apache. I resetted all the file-ownerships tot "user", thats why the plugin wasn't working for me.

  15. sommerinhamburg
    Member
    Posted 1 year ago #

    Works. Thank you, geerthoekzema!

  16. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    @geerthoekzema is right. All of the complaints have been caused by switching how W3TC manages files to use the WP FileSystem API, working on putting things back as they once were still. Sorry for the trouble.

  17. Dob2806
    Member
    Posted 1 year ago #

    to correct the bug you just have to

    chmod -R 755 /var/www/vhosts/XXXXXXXXX/httpdocs/new/wp-content
    chown -R www-data:www-data /var/www/vhosts/XXXXXXXXX/httpdocs/new/wp-content
    and it's done no need to uninstall or something else !!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic