WordPress.org

Ready to get started?Download WordPress

Forums

GA Google Analytics
[resolved] Update v20131107 (8 posts)

  1. Zee Cornelius
    Member
    Posted 9 months ago #

    Hi Jeff

    I installed the latest version onto my WP but my GA is still showing me the message "Your Demographics and Interest Reports have been enabled, but your Analytics tracking code does not include the necessary support to show them."

    Anything I missed out on enabling?

    Thanks in advanced!

    http://wordpress.org/plugins/ga-google-analytics/

  2. Jeff Starr
    Member
    Plugin Author

    Posted 9 months ago #

    Hi Zee,

    Did you include your GA ID in the plugin settings? And then click to enable?

    To verify that the code is displayed, check the source code of your web page(s).

  3. Zee Cornelius
    Member
    Posted 9 months ago #

    Hi Jeff

    I did include my ID and enabled it too.

    I just checked on the source code against the GA support page (https://support.google.com/analytics/answer/2444872?hl=en&utm_id=ad)

    There is one line that is needed to be changed from:
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';

    to this:
    ga.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';

    Where can I edit this?

  4. Jeff Starr
    Member
    Plugin Author

    Posted 9 months ago #

    Did you try enabling the option to "Enable Display Ads?" That should do it I think..

  5. Zee Cornelius
    Member
    Posted 9 months ago #

    Oh my, Jeff. Thank you. I didn't realise the option was necessary.

    THANK YOU, JEFF! :)

  6. Jeff Starr
    Member
    Plugin Author

    Posted 9 months ago #

    You're welcome, glad you got it working! :)

  7. curryberry
    Member
    Posted 8 months ago #

    For me this option isn't working when using universal analytics. If disabling universal analytics, the script change correctly to the "doubleclick" line.

    Otherwise with "Enable Display Ads?" and "Universal Analytics?" both active it still shows the line:
    ...(window,document,'script','//www.google-analytics.com/analytics.js','ga');...

  8. Jeff Starr
    Member
    Plugin Author

    Posted 8 months ago #

    Hi curryberry,

    This thread was resolved and closed, but I'll take a look at your reported issue for the next update. FYI in the future please open a new thread for new topics. Thanks.

Reply

You must log in to post.

About this Plugin

About this Topic