WordPress.org

Ready to get started?Download WordPress

Forums

Akismet
Update to Akismet 2.5.6 fails with WP 3.1.4 (6 posts)

  1. roy547
    Member
    Posted 2 years ago #

    The following error message comes up only when Akismet 2.5.6 is activated:
    Warning: Missing argument 2 for wp_widget() in /usr/local/pem/vhosts/267049/webspace/siteapps/143501/htdocs/wp-includes/widgets.php on line 76

    Version 2.5.3 had been working without problems. I'd like to go back to it.

    http://wordpress.org/extend/plugins/akismet/

  2. Joseph Scott
    Member
    Plugin Author

    Posted 2 years ago #

    The proper fix is to upgrade from PHP 4 to PHP 5.2 or higher. WordPress no longer supports PHP 4.

  3. roy547
    Member
    Posted 2 years ago #

    That's nice when you control the server but most of us are tenants on a bigger system and the php version is what it is. I'd be happy to go back to akismet 2.5.3. Using older versions isn't mentioned on the Akismet site so I shall just have to not use it at all.
    roy547

  4. Joseph Scott
    Member
    Plugin Author

    Posted 2 years ago #

    Version 2.5.3 of the plugin is available at http://downloads.wordpress.org/plugin/akismet.2.5.3.zip

    If your host isn't willing to update versions of PHP that have officially been deprecated years ago then it is time to start looking for a better host.

  5. Sergey Biryukov
    WordPress Dev
    Posted 1 year ago #

    The proper fix is to upgrade from PHP 4 to PHP 5.2 or higher.

    Agreed. However, Akismet 2.5.6 still lists WordPress 3.0 as the minimum required version.

    It guess either the required version should be bumped to 3.2, or a PHP 4 constructor should be added to akismet/widget.php.

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    Akismet 2.5.6 still lists WordPress 3.0 as the minimum required version.

    We've asked the Akismet people to look into this.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic