WordPress.org

Ready to get started?Download WordPress

Forums

Update Services Ping Not Working (8 posts)

  1. Alan
    Member
    Posted 10 years ago #

    I'm Using 1.2-beta and have two URIs entered on two lines in the Update Services field...but neither service is being pinged when I publish.
    http://rpc.weblogs.com/RPC2
    http://ping.blo.gs/
    I hope this is a bug and not a problem with my site alone. :\

  2. Laughinglizard
    Member
    Posted 10 years ago #

    There is a bug in the code which should be fixed soon. A temporary fix can be to find the line below in your wp-includes/functions.php:
    function weblog_ping($server = '', $path = '') {
    and to add this line just below that line:
    include_once('class-xmlrpc.php');

  3. nefarious
    Member
    Posted 10 years ago #

    Using 1.2-epsilon-RC1 ... still broken. Any ideas when this is going to get fixed?
    Is the temp fix posted by LaughingLizard the actual/end fix that will be rolled out?
    Thanks,
    -nef

  4. nefarious
    Member
    Posted 10 years ago #

    LaughingLizard, I made the change you suggested and am still not sending a ping to any of the services I have in my 'Update Services' textbox.

    http://rpc.blogrolling.com/pinger/
    http://rpc.weblogs.com/RPC2
    http://ping.blo.gs/
    http://api.my.yahoo.com/RPC2

  5. bgk
    Member
    Posted 10 years ago #

    nefarious,
    The problem here is with the class-xmlrpc.php file. For a start the constructor for xmlrpcvar isn't behaving itself in the RC1 release. If you check out the latest version of the source from CVS someone has hacked around and made it work ;).
    I wish /I/ had bothered to look for updated files, could have saved myself an hour tracking it down and doing a custom fix.
    -BK

  6. nefarious
    Member
    Posted 10 years ago #

    Woot... RC2 is working :-)

  7. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    Remember, you really only have to ping one:
    http://rpc.pingomatic.com/

  8. ihad
    Member
    Posted 8 years ago #

    hmm shouldn't wp-stats show me when blo.gs and others ping back? I have http://rpc.pingomatic.com/ in my settings yet the ping seems to work very seldom. When I manually ping technorati or blo.gs I get the result in wp-stats shown...

    maybe I am doing something wrong or it's simply not working...?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.