WordPress.org

Ready to get started?Download WordPress

Forums

update plugin error (8 posts)

  1. OperaManiac
    Member
    Posted 5 years ago #

    Downloading update from http://downloads.wordpress.org/plugin/all-in-one-seo-pack.zip
    
    Unpacking the update
    
    Deactivating the plugin
    
    Removing the old version of the plugin
    
    Could not remove the old plugin
    
    Plugin upgrade Failed

    I am facing this problem with any plugin update on my blog. this used to work earlier but i cannot update my plugins from the backend any more.

  2. jcow
    Member
    Posted 5 years ago #

    I am no expert on this process for sure. My first thought, though, is that it might be a permissions problem? chmod.

  3. OperaManiac
    Member
    Posted 5 years ago #

    well... plugins are managed through FTP right? i have never chmod the plugin folder 666 or 777 in the past for this functionalities.

  4. OperaManiac
    Member
    Posted 5 years ago #

    Alright. I had one blog on 2.7 and not 2.7.1... plugin update from the wordpress backend works fine on it :)

  5. gmustuk
    Member
    Posted 5 years ago #

    I have the same problem....and this happens to just about all the plugins that I install through the admin interface.

    If I try to upgrade the plugin after the install it won't work. Basically it seems that it uses the servers security credentials rather than the general FTP account credentials so when you try to upgrade (using the FTP info that wordpress asks for) it doesn't have access. I have to login with a root login...delete the plugin...and then manually ftp upload/activate the plugin.

    I'm searching for a solution, but there needs to be a way to have control over what user/group the plugin files/dir are created with so that upgrades can properly remove and replace the plugin with the same access account.

  6. OperaManiac
    Member
    Posted 5 years ago #

    this problem continues on a random basis.

    same server. different blogs. plugin update from the backend works fine on some blogs. while it gives an error on others.

  7. jimjam
    Member
    Posted 4 years ago #

    This is still happening, tried loads of different "solutions" but none of them worked :-(

  8. OperaManiac
    Member
    Posted 4 years ago #

    i have myself given up on this feature of wordpress!

    i just keep a folder of all the plug-ins i use and just upload the complete folder to all the blogs i manage for myself and friends.

    it's painful but works without any surprises.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.