WordPress.org

Ready to get started?Download WordPress

Forums

Update Permalink Structure => You should update your .htaccess now. (3 posts)

  1. podictionary
    Member
    Posted 7 years ago #

    I have a wordpress implementation structured with the blog address at the domain level (www.podictionary.com) using the index.php and .htaccess files in that folder, and the wordpress files & folders at podictionary/wordpress

    When I follow an instruction to "Update Permalink Structure" I get the message "You should update your .htaccess now."

    As instructed at http://codex.wordpress.org/Using_Permalinks I have set permissions to the .htaccess file to be 666 (one place in the forums recommended 777 – tried that too, didn't work). Also on that codex page there is an instruction to correct a possible "server blockage" by setting $is_apache = 1; I tried that too without success.

    I note that at http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory instruction 11 states:
    If you have set up Permalinks, go to the Permalinks panel and update your Permalink structure. WordPress will automatically update your .htaccess file if it has the appropriate file permissions. If WordPress can't write to your .htaccess file, it will display the new rewrite rules to you, which you should manually copy into your .htaccess file (in the same directory as the main index.php file.)

    In my case I do not see any display of "new rewrite rules" that I could copy.

    NOTE: for some reason I have index.php and .htaccess files also in the wordpress folder, content of the .htaccess files are identical, reading:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>
    # END WordPress

    The index.php files are almost, but not exactly identical
    in the podictionary folder index.php reads:

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wordpress/wp-blog-header.php');
    ?>

    In the wordpress folder index.php reads:

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wp-blog-header.php');
    ?>

    The website appears to function correctly.

    However, when using the podPress plugin under podPress>general if I choose "Enable podPress Statistics" I get the following message:

    Warning: It appears you are not using WordPress permalinks or 404 handling. Due to this enabling podPress stats may cause media file downloads to fail.
    According to WordPress, if your .htaccess file in your main WordPress directory were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file.

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    I also note that this code is close (but not identical) to what is actually already in my .htaccess file (mine has /wordpress/ in there too)

    Moreover I note that contrary to the warning, media file downloads appear to work.

    In summary I think WordPress can't write to the .htaccess file (or thinks it can't) and correcting this could resolve these error messages. Any clues?

  2. podictionary
    Member
    Posted 7 years ago #

    Since no one seems to be able to help with this one, here's a question that might have an easier answer, and might even answer this one: If once-upon-a-time I set the permalinks to something other than the default (ugly) type, then reversed that (back to default), was some switch set that makes these error messages come up?

  3. tvsnacks
    Member
    Posted 7 years ago #

    I bet I am having a similar problem - I'm getting 404s all over the place and I have a feeling it's because of my permalinks.

Topic Closed

This topic has been closed to new replies.

About this Topic