WordPress.org

Ready to get started?Download WordPress

Forums

Page Builder by SiteOrigin
Update not working with Snapshot (6 posts)

  1. cp1091
    Member
    Posted 1 year ago #

    Hello,

    I have the premium version of Snapshot (Love it), but just updated and am receiving this error for Page Builder

    Plugin could not be activated because it triggered a fatal error.
    Fatal error: Cannot redeclare siteorigin_panels_admin_menu() (previously declared in /home/villanov/cameronpiper.com/wp-content/themes/snapshot/extras/panels/panels.php:14) in /home/villanov/cameronpiper.com/wp-content/plugins/siteorigin-panels/siteorigin-panels.php on line 70

    This happens when I try to update Page Builder and activate it as well.

    Due to this, my homepage is all messed up because the widgets won’t appear.

    Please help!

    Cameron

    http://www.cameronpiper.com

    http://wordpress.org/extend/plugins/siteorigin-panels/

  2. Greg Priday
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Cameron

    The problem there is that Snapshot has a bundled (be it slightly older) version of Page Builder by default. The 2 versions of Page Builder are conflicting.

    My other themes have functionality that allows the Page Builder plugin to overwrite the bundled theme version of Page Builder. I'll add this to Snapshot and Snapshot Premium ASAP. I'll post a message here when the auto-update is available.

    Sorry about that!

  3. Greg Priday
    Member
    Plugin Author

    Posted 1 year ago #

    Oh wait, turns out I've already updated Snapshot to deal with the plugin version of Page Builder. Just make sure that you're using the latest version (1.2.4 of Free or 2.2.4 or premium). You should see an auto update available, or else use this form to get the latest version of Premium.

  4. cp1091
    Member
    Posted 1 year ago #

    Hello Greg,

    Thank you for your quick response. I had updated to 2.2.4 before posting, and it seems like the update is bundled with Page Builder 1.2.1, which I cannot update due to this error. Check if you may have bundled the incorrect version with your update of Snapshot.

    Thanks!

  5. Greg Priday
    Member
    Plugin Author

    Posted 1 year ago #

    Can you drop an email to support@siteorigin.com? I might need a temp admin account to log in and get everything sorted out :)

  6. Greg Priday
    Member
    Plugin Author

    Posted 1 year ago #

    Never mind, just spotted your email. I'll reply there.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.