WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] update gone wrong (6 posts)

  1. austincourson
    Member
    Posted 1 year ago #

    So i hosted my own blog with 1and1 when my wife and i went to the UK in 2010. I havent touched the blog since then and now we are going to Ireland in a few months so i decided to dust it off. It's pretty out of date so i decided to update it to 3.5. Followed the instructions from the wiki. I backed up my database through myPHP ( did not just backup the whole site through FTP which was really stupid). When i was all done PHP was out of date. Decided to forget it and reinstalled 2.6. whatever to try to revert back. Tried importing database to get it all back to the original but its all screwed up. its like its a band new site when i try and load it asking to setup a config file.
    Any pointers on trying to revert or anyway to salvage the mess i have created?

    this is what it says now
    Warning: require(/homepages/19/d314891559/htdocs/acrossthepond/wp-includes/class-wp.php) [function.require]: failed to open stream: No such file or directory in /homepages/19/d314891559/htdocs/acrossthepond/wp-settings.php on line 66

    Fatal error: require() [function.require]: Failed opening required '/homepages/19/d314891559/htdocs/acrossthepond/wp-includes/class-wp.php' (include_path='.:/usr/lib/php5') in /homepages/19/d314891559/htdocs/acrossthepond/wp-settings.php on line 66

    http://acrossthepond.austincourson.com

  2. austincourson
    Member
    Posted 1 year ago #

    SQL query:
    
    -- phpMyAdmin SQL Dump
    -- version 2.6.4-pl3
    -- http://www.phpmyadmin.net
    --
    -- Host: db2314.perfora.net
    -- Generation Time: Dec 24, 2012 at 12:22 AM
    -- Server version: 5.0.96
    -- PHP Version: 5.3.3-7+squeeze14
    --
    -- Database: <code>db320269081</code>
    --
    -- --------------------------------------------------------
    --
    -- Table structure for table <code>wp_commentmeta</code>
    --
    CREATE TABLE  <code>wp_commentmeta</code> (
    
     <code>meta_id</code> BIGINT( 20 ) UNSIGNED NOT NULL AUTO_INCREMENT ,
     <code>comment_id</code> BIGINT( 20 ) UNSIGNED NOT NULL DEFAULT  '0',
     <code>meta_key</code> VARCHAR( 255 ) DEFAULT NULL ,
     <code>meta_value</code> LONGTEXT,
    PRIMARY KEY (  <code>meta_id</code> ) ,
    KEY  <code>comment_id</code> (  <code>comment_id</code> ) ,
    KEY  <code>meta_key</code> (  <code>meta_key</code> )
    ) ENGINE = MYISAM AUTO_INCREMENT =87 DEFAULT CHARSET = utf8 AUTO_INCREMENT =87
    MySQL said: 
    
    #1046 - No database selected
  3. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 1 year ago #

    it looks like you failed to select the database name in the left panel when you tried to import the db backup

  4. phpsundar
    Member
    Posted 1 year ago #

    you can't do direct upgradation from FAR LOWER VERSION TO LATEST VERSION (ie) from 2.6 to 3.5 directly.
    You have to upgrade 1 version at a time
    (ie) 2.6 -> 2.7 -> 2.8 & so on.
    Also you can try doing 2 version for single upgrade like
    2.6 -> 2.8 -> 3.0

    This might be time consuming & cumbersome , but this is the only way , because there were lot of files & functions deprecated in the newer versions.
    Also 3.5 supports only PHP 5.2.4 & above , also MySQL 5 & above
    So make sure your webserver is upgraded too

  5. austincourson
    Member
    Posted 1 year ago #

    after some fiddling i now have this error on my page
    Fatal error: Call to undefined function: date_default_timezone_set() in /homepages/19/d314891559/htdocs/acrossthepond/wp-settings.php on line 36

  6. austincourson
    Member
    Posted 1 year ago #

    Must be a Christmas miracle it's workin again. Thanks for all your help

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.