WordPress.org

Ready to get started?Download WordPress

Forums

Quick Cache (Speed Without Compromise)
[resolved] Update crashed all sites on Host Gator (4 posts)

  1. msqinc
    Member
    Posted 8 months ago #

    All sites went down with very ugly error after update.
    I had to ftp into each site and manually remove the plug in. Error:

    Fatal error: Uncaught exception 'Exception' with message 'This version of Quick Cache requires PHP v5.3+.' in /xxx/xxx/xxx/xxxx.us/wp-content/plugins/quick-cache/quick-cache.php:19 Stack trace: #0 //xxx/xxx/xxx/xxxx.us/wp-settings.php(203): include_once() #1 /xxx/xxx/xxx/xxxx.us/wp-config.php(106): require_once('/xxx/xxx/p...') #2 /xxx/xxx/xxx/xxxx.us/wp-load.php(29): require_once('/home1/msqinc/p...') #3 /xxx/xxx/xxx/xxxx.us/wp-admin/admin.php(30): require_once('/xxx/xxx/p...') #4 /xxx/xxx/xxx/xxxx.us/wp-admin/index.php(10): require_once('/xxx/xxx/p...') #5 {main} thrown in /xxx/xxx/xxx/xxxx.us/wp-content/plugins/quick-cache/quick-cache.php on line 19

    http://wordpress.org/plugins/quick-cache/

  2. Raam Dev
    Member
    Plugin Author

    Posted 8 months ago #

    @msqinc My sincere apologies for that. Quick Cache v131127 and v131128 (released a few versions back now) improved handling of PHP 5.3 detection:

    Compatibility. This release improves PHP v5.3 detection. Quick Cache will now generate an administrative notice instead of a PHP exception; allowing the plugin to be activated, but without actually loading the plugin under this scenario. A notice to the site owner is helpful in cases where the plugin is NOT being updated through the Dashboard. This will remove the risk of crashing a site that's attempting to run Quick Cache w/o PHP v5.3+ installed. See also: https://github.com/WebSharks/Quick-Cache/issues/13

    See also: http://wordpress.org/plugins/quick-cache/changelog/

  3. borderline11
    Member
    Posted 8 months ago #

    so basically , unless you have php 5.3 there is no point to install this updated version, right?

  4. Raam Dev
    Member
    Plugin Author

    Posted 8 months ago #

    @borderline11 Yes, as of v131121, Quick Cache requires PHP 5.3+. If your web host does not have PHP 5.3+ on the server, I highly recommend asking them to upgrade PHP.

    Otherwise, if you absolutely cannot upgrade to PHP 5.3+, you can still use the old release of Quick Cache (released December 2011) here: http://downloads.wordpress.org/plugin/quick-cache.111203.zip

Reply

You must log in to post.

About this Plugin

About this Topic