WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Update checks, Feeds, and are inaccessible (14 posts)

  1. computerslayer1
    Member
    Posted 9 months ago #

    I just updated to 3.7.1 from the latest version of 3.6.

    After upgrading, the dashboard feeds simply displayed the error "RSS Error: WP HTTP Error: couldn't connect to host".

    Update checks produced errors in log files:

    [05-Nov-2013 17:38:53 UTC] PHP Warning:  An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the <a href="http://wordpress.org/support/">support forums</a>. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /home/.../public_html/wp-includes/update.php on line 112
    [05-Nov-2013 17:39:05 UTC] PHP Warning:  An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the <a href="http://wordpress.org/support/">support forums</a>. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /home/.../public_html/wp-includes/update.php on line 259
    [05-Nov-2013 17:39:17 UTC] PHP Warning:  An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the <a href="http://wordpress.org/support/">support forums</a>. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /home/.../public_html/wp-includes/update.php on line 399

    If I go to the "install plugins" plugins page, these error messages are displayed:

    Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /home/.../public_html/wp-admin/includes/plugin-install.php on line 77
    
    An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums.

    Basically, it looks like this installation of wordpress can't access any sources of data hosted outside of wordpress.

    Any ideas?

  2. hasanbulli
    Member
    Posted 9 months ago #

    I had a similar problem to the feeds before I upgraded to 3.7.1. However, that was because I am behind a firewall. I fixed that by defining proxies in my wp-config.php.

    I still have the problem with plugin updates though. Although everything updates manually, I get those errors. I am assuming that it is because of the new feature of 3.7.1 and related to proxy as well.

    I will post again if I find any solution.

    Good luck!

  3. Miiz
    Member
    Posted 9 months ago #

    I have the same issue..

    Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /home/public_html/wp-admin/includes/plugin-install.php on line 77

    An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums.

  4. Nikki Blight
    Member
    Posted 9 months ago #

    I'm not having the issue with RSS feeds, but I am seeing the error on the updates page regarding plugin-install line 77.

  5. susanarios14
    Member
    Posted 9 months ago #

    I have the same issue when i go to install plugins-> An unexpected error... on line 77

  6. computerslayer1
    Member
    Posted 9 months ago #

    It looks like this issue was not related to the upgrade. My host said they made a routing change, which inadvertently broke a few things.

  7. susanarios14
    Member
    Posted 9 months ago #

    is your webhosting Hostgator??

  8. Danial Hatami
    Member
    Posted 9 months ago #

    I have the same problem !

    wp-admin/includes/plugin-install.php on line 77

    can't search and install any plugin !

    I said the problem to the host manager and he said there is no problem with host !

  9. computerslayer1
    Member
    Posted 9 months ago #

    @susanarios14: No, I am not using hostgator.

  10. pleydesigns
    Member
    Posted 9 months ago #

    No it is not a hosting provider problem but something in the code as I am on straight cPanel/WHM installs on dedicated servers I own and same thing is happening to all of our installs after upgrading to 3.7.1. Now after leaving the install alone for a bit it seems it automaticly updates to the latest versions of everything. Kind of weird if you ask me and possibly bad coding on WordPress's side.

  11. esmi
    Forum Moderator
    Posted 9 months ago #

    @pleydesigns: If you require assistance then, as per the Forum Welcome, please post your own topic. This topic has been resolved.

  12. nick_nielsen
    Member
    Posted 9 months ago #

    I have exactly the same problem - where is the "resolution" of this thread (apart from arbitrary closure)?

  13. WPyogi
    Volunteer Moderator
    Posted 9 months ago #

    It was resolved for the OP. if you need help, start your own thread as posted above.

  14. designpromote
    Member
    Posted 8 months ago #

    How about adding the following line to your wp-config.php:

    define( 'DISABLE_WP_CRON', true );

    to disable cron in WordPress.

Reply

You must log in to post.

About this Topic