WordPress.org

Ready to get started?Download WordPress

Forums

Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps)
[resolved] Update 3.6.4 Crashes Visual Editor (6 posts)

  1. NynAcm
    Member
    Posted 6 months ago #

    Hi Robert,

    As my title states, the newest update is crashing the Visual Editor on WP 3.6.1
    I've tried Re-installing, Deactivating "Other Plugins". it only comes back when I deactivate Leaflet

    Here is my Error LOG:
    It has to do with the Version of Leaflet, and then conflicting in not being able to load the Icon in the Visual Guide Icon Options for shortcode insertion.

    Please Advise.

    GET http://domain.com/wp-content/plugins/leaflet-maps-marker/inc/js/lmm_html_shortcode.php?leafletpluginurl=aHR0cDovL2VsYWluZXNiYWtlcnlhbmRjYWZlLmNvbS93cC1jb250ZW50L3BsdWdpbnMvbGVhZmxldC1tYXBzLW1hcmtlci8%3D&ver=3.6.1 404 (Not Found) post.php:40
    
    GET http://domain.com/wp-content/plugins/leaflet-maps-marker/inc/js/lmm_tinymce_shortcode.php?leafletpluginurl=aHR0cDovL2VsYWluZXNiYWtlcnlhbmRjYWZlLmNvbS93cC1jb250ZW50L3BsdWdpbnMvbGVhZmxldC1tYXBzLW1hcmtlci8=&ver=358-25336 404 (Not Found) wp-tinymce.php:2
    
    Failed to load: http://domain.com/wp-content/plugins/leaflet-maps-marker/inc/js/lmm_tinymce_shortcode.php?leafletpluginurl=aHR0cDovL2VsYWluZXNiYWtlcnlhbmRjYWZlLmNvbS93cC1jb250ZW50L3BsdWdpbnMvbGVhZmxldC1tYXBzLW1hcmtlci8=

    http://wordpress.org/plugins/leaflet-maps-marker/

  2. RobertHarm
    Member
    Plugin Author

    Posted 6 months ago #

    Hi,
    as you are the first one reporting this I'd rather guess this has another reason - possibly a plugin conflict. Can you please try disabling all other plugins to check if it works then? If not, please also try switching to twentytwelve to check if it is a theme conflict.
    If not, we will have to further investigate this issue...
    best,
    Robert

  3. NynAcm
    Member
    Posted 6 months ago #

    Thank you Robert,

    I have tried all of these, to no avail. I have your plug-in working on other sites on the same framework and updates, and versions.

    • All plugins deactivated
    • Default theme Activated
    • Only Leaflet Activated

    Still breaks the Visual Editor
    Still getting the Same Error
    I was very thorough, and i even had to rebuild my widgets due to this.

    As explained above, it's having trouble loading in the Icon into the visual editor in order to auto place the shortcode.

    Is there something I can do to deactivate it in the settings? Or a piece of code I can insert to block it from loading into the visual editor?

  4. RobertHarm
    Member
    Plugin Author

    Posted 6 months ago #

    please navigate to settings / misc and set the option "TinyMCE button" to disabled.
    best,
    Robert

  5. NynAcm
    Member
    Posted 6 months ago #

    This works!

    Thank you Very much, I must have missed that option.

  6. RobertHarm
    Member
    Plugin Author

    Posted 6 months ago #

    great to hear! closing ticket.
    PS: if you like using my plugin, I'd appreciate your review at http://wordpress.org/support/view/plugin-reviews/leaflet-maps-marker ;-)

Reply

You must log in to post.