WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Updaing PHP 5.4.x (5 posts)

  1. dylan.keys
    Member
    Posted 9 months ago #

    Hi When our host performs an update to ph version 5.4.x my site returns an error 500 message.

    I had a look at the php logs and this is what I get.

    [23-Jun-2013 17:29:52 Antarctica/Macquarie] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20090626/suhosin.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20090626/suhosin.so: undefined symbol: output_globals in Unknown on line 0
    [23-Jun-2013 17:29:52 Antarctica/Macquarie] PHP Fatal error: Directive 'register_globals' is no longer available in PHP in Unknown on line 0
    [23-Jun-2013 17:30:36 Antarctica/Macquarie] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20090626/suhosin.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20090626/suhosin.so: undefined symbol: output_globals in Unknown on line 0
    [23-Jun-2013 17:30:36 Antarctica/Macquarie] PHP Fatal error: Directive 'register_globals' is no longer available in PHP in Unknown on line 0
    [23-Jun-2013 17:30:36 Antarctica/Macquarie] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20090626/suhosin.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20090626/suhosin.so: undefined symbol: output_globals in Unknown on line 0
    [23-Jun-2013 17:30:36 Antarctica/Macquarie] PHP Fatal error: Directive 'register_globals' is no longer available in PHP in Unknown on line 0

    The site and pluggins are up-to-date. If anyone has any ideas on what is causing this would love to know.

    Cheers,

  2. Lindsay T
    Member
    Posted 9 months ago #

    This is an error on your host's side. You could contact them with the error messages you posted.

  3. Yui
    Member
    Posted 9 months ago #

    If you have access to php.ini (if you use shared hosting - ask support instead!)

    suhosin extension - not available in php 5.4 and must be disabled
    register_globals must be removed from php.ini , its not secure and is not supported anymore

  4. dylan.keys
    Member
    Posted 9 months ago #

    Thanks for the suggestions but they did not work.

  5. dylan.keys
    Member
    Posted 9 months ago #

    Have fixed this by using my host default php.ini instead of the custom one in my home directory.

Reply

You must log in to post.

About this Topic

Tags