WordPress.org

Ready to get started?Download WordPress

Forums

Unwanted white space at top of page (2 posts)

  1. Ian McLeish
    Member
    Posted 2 years ago #

    Hi, I am brand new to WP, but already run into my first problem.
    I am new, but wanted to customise my nonzero them from a 3 column to a 2 column, so first thing I did was copied the page.php in the theme and renamed it. Everything in the two files is identical except for the code

    <?php 
    
    /* Template Name: NoSidebar */ 
    
    ?>

    Inserted at the top to call this file NoSideBar.php and have it seen as a page template. It works fine, except that there is a text sized white bar at the top of the masthead. It will disappear if I change change back to default template, but I cannot understand why if the files are otherwise identical, which they are definitely. (all I did was Save As to copy the one file to a new one (in Web Expression), then added the template name.

    I read about issues with the space being for the admin bar, but the white remains whether logged in or not, admin bar enabled or not, in IE FF and Chrome. This is latest WP installed through webmatrix on laptop, only for testing and messing at the moment.

    I have searched a lot, but many make css suggestions, which I think can't apply here as the two files are the same barring the names.

    Any suggestions would be very gratefully received.
    Ian

  2. peredur
    Member
    Posted 2 years ago #

    Please post a link to your site, or we can't see what's going on.

    If you can't do that, you'll have to look for the culprit yourself. The usual method is to use Firebug to identify the element whose style you want to change. You then define a rule for that element that will replace the original.

    In this case, you will probably want to use display: none; on the element (see this article).

    HTH

    PAE

Topic Closed

This topic has been closed to new replies.

About this Topic