WordPress.org

Ready to get started?Download WordPress

Forums

unwanted non-breaking spaces permeating post text (10 posts)

  1. lionsrest
    Member
    Posted 7 years ago #

    I've searched, and found no discussion of this. Writing posts, I invariably end up with a line or two in the middle where every normal space is replaced with HTML non-breaking spaces ( ). This is making the line in question extend well beyond the borders of the post area when viewing. I was getting this behavior with a totally standard WP install, and when I tried to use the HTML editor there, it always trashed my post contents. I installed the editMonkey plugin, and while the HTML editor now works, the non-breaking spaces still happen.
    Using WP 2.0.3, server has PHP Version 4.4.1, computer is Windows XP pro (up to date), and Opera 9.01 (suggestions to switch to different browsers will be ignored).

  2. tsguitar
    Member
    Posted 7 years ago #

    A link to the problem would be nice. There's no reason I can think of that WordPress would plug in a bunch of   into your post. That doesn't make sense, so I'd like to see it to guess what's happening.

    If I had to guess right now, I'd say you've got a line with a bunch of spaces in it while you're editing your post. Are you cutting and pasting from Word or something? Or composing your post right there in WordPress?

  3. lionsrest
    Member
    Posted 7 years ago #

    The problem is not visible in any of my existing posts because I manually clean the non-breaking spaces out with the HTML editor before publishing.

    I've not pasted in anything but simple text, and several posts where this occurred had nothing pasted in at all. All posts I compose right there in WordPress.

    I just tried starting two new posts, and of course, it's not happening now.

    *sigh* I'm sure I now look to be an idiot who just likes to complain. If it happens again, I'll try to document what I did, and save it as is, and come back here. Sorry to have wasted your time.

  4. manstraw
    Member
    Posted 7 years ago #

    You're writing this somewhere else and pasting it in? That would be the source of the problem. Try either writing it in the wordpress entry screen, or pick something that won't stick it's own formatting in there, like notepad. Even if you get it from somewhere else, running it through notepad will help clean it up. Just paste it in, deselect, select all, copy, and back to wordpress to paste.

  5. maerk
    Member
    Posted 7 years ago #

    If you're using plain text, you could disable the rich text editor. That way you can use whatever HTML you like.

  6. lionsrest
    Member
    Posted 7 years ago #

    manstraw, What?? I'm using the WordPress entry screen editor, NOT writing it elsewhere and pasting it in.
    I said "All posts I compose right there in WordPress."

    Since I can't reproduce the problem now, and have no examples I didn't manually clean up, I don't know what can be said that will help. Obviously, considering no one has said it's a known issue, it's likely some mistake I unknowingly made.

    Thanks for responding everyone.

  7. manstraw
    Member
    Posted 7 years ago #

    sorry, I misread something which gave me the impression you were pasting from an other source and editing. the thing I mention is a common problem, but it obviously doesn't apply to you.

    beats me what happened. i've never seen what you describe when editing within the wordpress entry screen.

  8. antoszka
    Member
    Posted 7 years ago #

    Hello -- I'm getting exactly the same problem. These non-breaking spaces just get inserted randomly, what's more they don't seem to be visible in the code as   even though the effects of their existence are clearly visible both in the visual editor (by an aburd forced linebreak before a series of words with these spaces) and in the blog as rendered by a browser. Maybe the editor inserts some magic unicode non breaking spaces that are not visible in the source encoded by &nbps;, but are directly inserted as an utf-8 character?

    Trying randomly to replace spaces in the post by deleting them and entering them again ususally fixes the problem.

    Any ideas?

  9. dymonaz
    Member
    Posted 7 years ago #

    I have exactly the problem described - I believe it is only the Opera issue and sure - switching a browser is not an option. The problem itself is character 160 (aka  ) being used instead of the usual 32 when spacebar is pressed. Going backwards, removing the character and pressing spacebar again fixed that, but considering you have to do it for half of the post - it's REALLY annoying.

    This seems to happen after some events which the editor and/or wordpress do - i.e. autosave, pasting something, using ctrl + arrow key to jump words. I haven't pinpointed what EXACTLY is the problem, but I generally already know (or just feel) that this will happen.

    WP2.1 / Opera 9.1

  10. bhemkemeier
    Member
    Posted 7 years ago #

    I can confirm this problem with the combination of WP 2.1 and Opera 9.10.

    It is very annoying that

    i) the problem begins randomly and
    ii) the strange non-breaknung spaces are not visible in simple UTF-8 encoding.

    Unfortunately I am not able to reproducable example but this is definitly a bug.

Topic Closed

This topic has been closed to new replies.

About this Topic