WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Unwanted https redirect (9 posts)

  1. robinparrish
    Member
    Posted 3 months ago #

    When I click on Pages in the Dashboard menu, it redirects to an https connection, which returns a 404 error. So I can't access/edit Pages at all in WP. Pages is the only part of my site that does this, and my host's tech support can't figure it out.

    Can anyone help?

  2. esmi
    Forum Moderator
    Posted 3 months ago #

    What urls do you have entered in Settings -> General?

  3. robinparrish
    Member
    Posted 3 months ago #

    WordPress address and Site address are both set to http address. No https in sight.

  4. bemdesign
    Member
    Posted 3 months ago #

    Whats your permalink settings like?

  5. robinparrish
    Member
    Posted 3 months ago #

    I use a custom structure: /%category%/%postname%/

    The Category base and Tag base fields are blank.

  6. mechx1
    Member
    Posted 3 months ago #

    Are you running a security plugin that can force SSL connections for certain assets?

  7. robinparrish
    Member
    Posted 3 months ago #

    That was it! I had the "WP e-Commerce" plugin (that I hadn't started using yet) that was apparently sending all Pages to secure URLs.

    Many thanks to you all!

  8. mechx1
    Member
    Posted 3 months ago #

    You are welcome. Mark thread resolved please, it is appreciated

  9. robinparrish
    Member
    Posted 3 months ago #

    Done.

Reply

You must log in to post.

About this Topic