WordPress.org

Ready to get started?Download WordPress

Forums

Unwanted 'Home' page and blank menu (8 posts)

  1. NestaHinx
    Member
    Posted 1 year ago #

    Hello (said while tearing out hair)

    I'll be brief, as my life is drawing to a close because of two WordPress 'non-solvable' problems. If you can assist, I will (i) live; (ii) be eternally grateful; and (iii) celebrate with a cup of tea and a biscuit.

    1. Menu with no Page titles
    I am new to WordPress. I am creating only my second site using template Twenty Twelve. I have 'added' four new pages: Welcome, The author; Contact; FAQs. None of these titles shows up in the menu. (I have not created a 'custom menu' but when I tried this, as a solution, I could create the menu but no Pages were available in the 'Pages' panel on the left of the window to drag into my new custom menu.)

    When I publish 'publicly', the menu titles appear. When I am in 'draft' or 'publish privately', they disappear, although I am 100% sure this is not the case (as it worked OK with my first WordPress website, albeit using template Twenty Ten.

    2. Unwanted 'Home' page
    Although I did not create a 'Home' page and although a Page called 'Home' does not appear in my list of Pages (when I show all), a Home page is all that appears when I select 'Visit site'. Strangely, it bears the site title and the header image but nothing else. How did this happen and how can I get rid of it? The menu is empty except for the Page title 'Home'.

    Now, back to pulling my hair out until help arrives. Thank you in anticipation.

  2. april.davis
    Member
    Posted 1 year ago #

    Let me make sure I understand.

    1.Your pages set as "draft" or "publish privately" are not showing up in your navigation bar? When the pages are set to "publish publicly" are they showing in the navigation bar?

    The settings "draft" and "publish privately" are intended for the pages to not be viewed by the public. What is your intention for these pages? Are you wanting these pages to be available to site visitors?

    2. Home page: this takes you back to the main page of your site. You can set the "main page" in the dashboard under "Settings" "Reading."
    You can also set which page will be your designated "blog page" if you would like to.

  3. NestaHinx
    Member
    Posted 1 year ago #

    Thank you for replying so quickly.

    1. Yes, that is correct. And yes, I will want them available to all visitors once I have finished their design and build. At the moment, I am changing text and importing photos and generally finishing them off before I go 'public' to the outside world.

    2. I do not want any blog pages. The four pages will all be static pages. You say that 'Home' page will take me back to the main page, which I understand. But where did this 'Home' page come from and how do I delete it so it doesn't exist or confuse people? 'Home' page does not appear in my list of pages: it only appears when I 'view site' (and then, no other pages appear).

    I will read the forum post link you sent me, many thanks.

  4. april.davis
    Member
    Posted 1 year ago #

    What page would you like for visitors to see first when they visit your site?

    If your pages are set to "draft" visitors won't be able to get to them even if the page shows up in the navigation.

    If you really want them to show in the navigation while they are in draft-mode, go to your dashboard. Select "Appearance" and then "menus." Make a new menu. On the left-hand side you should see boxes labeled "Theme Locations," "Custom Links," "Pages," and so on...

    In the box "Custom Links" enter the URL for the page you want in your navigation bar. Then enter the name for the link such as "About Us" or "Contact." Do this for each page you want in your navigation bar.

    Now, be sure to set "Theme Locations" to your newly created menu. This should be the first box on the left on the "Menus" page. My theme only shows 1 Menu option which is called "Header Menu," however, some themes allow multiple menus. Be sure you select the correct menu for your theme.

    Note** you will have a blank front page on your website until you tell your wordpress installation which page you would like to be the front page or if you want posts to load on your front page. You can change this by following these steps:

    Go to Dashboard, settings, reading.
    Choose "A static page" and then next to "front page" select the page that you have created that you would like for your visitors to see when they first arrive to your site.

  5. NestaHinx
    Member
    Posted 1 year ago #

    Thank you April.

    I can see everything you have described. Thank you.

    As regards the second query 'Home' front page: when I go to 'Dashboard', then 'Settings', then 'Reading' I can only see a few 'Reading settings'. I do not see any options for choosing a specific Page.

    This is what I see:

    Reading Settings
    Blog pages show at most posts
    Syndication feeds show the most recent items
    For each article in a feed, show
    Full text
    Summary

    Search Engine Visibility Discourage search engines from indexing this site
    It is up to search engines to honor this request.

    Am I looking in the wrong place?

    Thank you for your time. Greatly appreciated.

  6. april.davis
    Member
    Posted 1 year ago #

    Mine shows all that you listed, however, right below "Reading Settings" it shows "Front Page displays with two options: "your latest posts" and "A static page"

    Make sure at least one of your pages is published publicly to make sure this shows up.

  7. NestaHinx
    Member
    Posted 1 year ago #

    Thank you April.

    At first, I didn't understand your instruction but when I 'publicly published' one page and selected Settings', then 'Reading', the choice of 'latest posts' or 'static page' appeared.

    I changed this as you advised and my 'Home' page is now my 'Welcome' page - which is what I wanted. I still don;t know why and I still don;t know how anyone would work that out without the sort of assistance you provided.

    Thank you very much indeed. I owe you a cup of tea! A large one.

  8. april.davis
    Member
    Posted 1 year ago #

    I'm glad this worked out for you and that I was able to help. Best of luck!

Topic Closed

This topic has been closed to new replies.

About this Topic