WordPress.org

Ready to get started?Download WordPress

Forums

Unrespsonsive Script error in Add New Post, WP 3.2.1 (10 posts)

  1. TheBeardedOne
    Member
    Posted 2 years ago #

    Getting Unresponsive Script message after upgrade to 3.2.1 from 3.1.4.

    After adding in
    define('CONCATENATE_SCRIPTS', false );

    the offending item shows to be from wp-includes/js/jquery/jquery.js?ver=1.6.1:16

    Did an MD5sum of the files from the 3.2.1 zip file and compared to those on the server, and all came out OK.

    Safari and Firefox will get the script error, IE will not display TinyMCE editor components.

    Even ran the MySQL query: DELETE FROM wp_postmeta WHERE post_id = '0'; no change.

    I'm at a loss as where to go next...

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Try re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

  3. TheBeardedOne
    Member
    Posted 2 years ago #

    No change, even when I copied over the files. Like I said, all the files checked out when doing an MD5 comparison before.

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  5. TheBeardedOne
    Member
    Posted 2 years ago #

    I've just got done doing all 3 and the problem still remains.

  6. TheBeardedOne
    Member
    Posted 2 years ago #

    Here's something that I've notice when doing a full refresh on the Add New page. The unresponsive script notice always appears after the GET for wp-admin/images/fade-butt.png. *BAM* The notice appears, click Continue running script. Then there is a GET for wp-includes/js/thickbox/loadingAnimation.gif. And then finally some POSTs for wp-admin/admin-ajax.php happen every few seconds. I'm watching this from Firefox's Web Console (Tools -> Web Developer -> Web Console). Hopefully this can help on stepping through the debugging.

  7. TheBeardedOne
    Member
    Posted 2 years ago #

    This all occurs with the twentyeleven theme active, plugins deactivated and then removed completely removed from the plugins directory (it is completely bare).

  8. esmi
    Forum Moderator
    Posted 2 years ago #

    Try adding define('CONCATENATE_SCRIPTS', false ); to the bottom of your wp-config.php file (just before the require_once line).

  9. TheBeardedOne
    Member
    Posted 2 years ago #

    I already have that in there. That's how I can tell it's referencing the wp-includes/js/jquery/jquery.js?ver=1.6.1:16 script file as the one being unresponsive.

  10. TheBeardedOne
    Member
    Posted 2 years ago #

    Found out the root cause of this problem.

    The delay was caused by the Author box (on the Add New post page) loading in all the users for our WP, which is right now around 95,000. We have this many since we do not allow anonymous comments and did not want to use an external comment system.

    The fix was to hardcode the users that would show up in the Author box, for use it meant the hand full with Author, Editor, and Admin status.

    In added in meta-boxes.php on line 530
    'include' => array(1,3,4),
    Where the number is the array are the user's ID numbers.

    This is a pretty major design flaw of WP that it will waste time and resources bringing in user names to attribute a post to, when those users are not able to make a post in the first place.

Topic Closed

This topic has been closed to new replies.

About this Topic