WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Unresolved Permalink Issue (27 posts)

  1. MAK
    Member
    Posted 8 years ago #

    Greetings,

    I'm absolutely begging for someone to help me! I have read EVERY POST regarding permalink issues and some are CLOSE to what I am experiencing but not exact.

    PROBLEM: I cannot get permalinks to work unless I use /index.php/ at the start of the permalink structure or use the default ugly links

    I have my blog at http://mak-az.dynu.com/makblog/
    I have the mod_rewrite module loaded in Apache
    I am using WP 2.0 (WP is supposed to do everything for me)
    I start with the default permalink structure (ugly links) -- EVERYTHING WORKS FINE!!!

    Everytime I try to update my permalink structure via the Admin Panel of WP it writes the following info to my .htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /makblog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /makblog/index.php
    </IfModule>

    # END WordPress

    NOTE: Notice the space after the period on the RewriteRule? Also the blank line before # END WordPress? There is also a blank line before # BEGIN WordPress.

    I have tried the following suggestions from the WP Codex:

    From Codex:
    1. If you leave whitespace at the end of your .htaccess file, it may make all pages on your site unavailable -- So I removed all whitespace. (Everytime WP updates the file it always adds whitespace, so I make sure to remove it.)

    2. I edited my wp-includes/vars.php file to say -- $is_apache = 1

    3. I edited my httpd.config file to say:
    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory>

    4. I deleted the contents of my .htaccess file and re-created it (by updating the permalink structure).

    NONE of those up above helped me.

    I have tried the following suggestions from other users:

    1. I added the UPDATED functions-post.php file and classes.php file
    2. I blanked out the .htaccess file (if I delete it WP doesn't create a new one; WP didn't even create one on fresh install I had to make it myself)
    3. I went to the permalink page in Admin Panel of WP and chose Date and Name based. That is supposed to give me the structure /%year%/%monthnum%/%day%/%postname%/.
    4. After doing that I check my .htaccess file again. My text editor tells me the file was updated by WP so I know it is being written to. When I look at the contents of the .htaccess file it just rewrites the same info I had before: (in otherwords nothing changed)

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /makblog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /makblog/index.php
    </IfModule>

    # END WordPress

    No matter which permalink structure I choose from the Admin Panel it keeps re-writing the exact same thing (as shown above) into my .htaccess file

    All I get are 404 page not found errors.

    Default link structure works (ugly links)
    http://mak-az.dynu.com/makblog/?p=27

    Date and Time structure works if I also add /index.php/ to the start of it (thus making it a custom structure)
    http://mak-az.dynu.com/makblog/index.php/2006/01/17/the-last-few-days/

    I do NOT want to have index.php/ as part of my URL. This is what I want below but I always get 404 errors.
    http://mak-az.dynu.com/makblog/2006/01/17/the-last-few-days/

    Nothing I have read on Codex or from users in this support forum works for me, not even adding the updated functions-post.php file and classes.php file.

    Can someone please help me, I'm getting so frustrated with this I just want to roll up in a ball and hide in a dark closet.

    Kindest Regards,

    ~ MAK

    STATUS: UNRESOLVED

  2. MAK
    Member
    Posted 8 years ago #

    Can someone please assist me on this?

  3. niziol
    Member
    Posted 8 years ago #

    MAK,

    You gave a very detailed description of the problem, but I noticed that you didn't mention maybe speaking to your webhost? I'm only assuming that you didn't because of the excellent detail of the issue!

    Your .htaccess looks exactly like mine does and mine works exactly like it should. Perhaps speak to your webhost and see if there is some issue they have or something like that.

    Other than that (which I hope for you is the case and that it can be fixed up quickly) I'm sure someone who is a pro with .htaccess could figure it out for you, sadly, this is not me!

    Good luck!

    Michael.

  4. MAK
    Member
    Posted 8 years ago #

    Hi Niziol,

    I host my own server.

    Tonight, again for the ump-teenth time, I went through every single post via a search that had anything to do with mod_rewrite, allowoverride, forbidden, permalinks, etc and nothing is working for me. I am either stuck using ugly links, or prefixing my permalinks with /index.php/

    I really can't stress how much I hate having the /index.php/ as part of my url but I guess it's better than ugly links. /sighs

    It just amazes me that so many people have this issue yet there is no solution not even in WP 2.0. There were 86+ posts asking for help on this and nearly all of them are still UNRESOLVED and quite a few of them are over a year old now. I know the older ones were regarding WP 1.5 to 1.3 to 1.2 but here we are with WP 2.0 and we still have this issue.

    What is annoying me is AllowOverride is set to None by default. If I change it to ALL or anything else WP won't let me access my blog, it gives me the 403 forbidden error. So I don't know what to do but giving up on trying to fix this seems most probable.

    Thanks for your reply.

    ~MAK

  5. MAK
    Member
    Posted 8 years ago #

    Here's an update:

    I don't know if I am getting closer to a solution or further from it.

    I changed AllowOverride None to AllowOverride All.

    This gives me 403 forbidden error everytime.

    If I keep AllowOverride All and also add
    Options +SymLinksIfOwnerMatch to the top of my .htaccess file I no longer get the 403 forbidden error but every page other than my homepage of blog gives me a 404 error instead.

    All my post links give me a 404 error. Some of my PAGE links work and some don't though I don't know what the difference is that makes some work and some not work.

    So is there something else I need to do or am I just further away from solving this?

    ~MAK

  6. taryn_
    Member
    Posted 8 years ago #

    Hi MAK -

    Well, after spending entirely too many hours sifting through the same messages and falling into the foulest of moods during the endeavor, I can offer this clumsy advice in order to fix mysteriously broken permalinks:

    RE-INSTALL WORDPRESS FROM SCRATCH, change the permalink structure once and then don't mess with it again.

    (the caps are for the benefit of those who scan these boards. I'm not yelling, really...)

    I deleted everything but wp-content, including the database. Then I uploaded all the WP files anew, stuck in a completely blank .htaccess, and ran install.php.

    Then I imported my old database from a backup, and THEN I switched my permalink structure, and now everything's as it should be.

    ...fingers crossed.

  7. MAK
    Member
    Posted 8 years ago #

    Hi Taryn,

    Are you then saying that you had the exact same problem as me or was your situation different?

    I have already re-installed this once but I forgot why other than I totally lost access to my blog. I fubar'd the database I think, I can't recall exactly ROFL.

    Anyhow, the point I am getting at is even before the re-install I had permalink issues and even now after-the-fact I still have it. I guess I'm saying I don't relish re-doing it all again if I don't have to, not because I am afraid of the job but because I am not confident it will change anything for me.

    Thanks for your reply though.

    Regards,

    ~MAK

  8. taryn_
    Member
    Posted 8 years ago #

    Yes, MAK - I had the exact same problem you did. In fact, I could have written your post myself. I tried every method you did, and met failure at every turn. Nothing but broken permalinks unless I opted for the uglies.

    By way of disclaimer, it wasn't careful thought that led me to scrap everything and start anew - more like a congenitally explosive temperament coupled with susceptibility to regret. In this case, the ending was a happy one.

    But, like you, I'm going to follow this thread to see if anyone comes up with a better idea.

  9. MAK
    Member
    Posted 8 years ago #

    Haha! Woot!!!

    After upgrading to WordPress 2.0.1 all my permalink problems appear to be gone! I can now use the date and time permalink structure like everyone else without using /index.php/ in my URL.

    I knew there was a bug and that it wasn't me, sweet deal!

    My Thanks go to all the WP devs. Awesome work!

    STATUS: RESOLVED

  10. guchuj05
    Member
    Posted 8 years ago #

    I've just upgraded to 2.01 and I can't get permalinks to work. No matter what I change it to it just uses the default structure. I've updated my .htaccess file manually--for some reason WP said it wasn't writable, which it was. But if anyone has any advice, I'd appreciate it.
    Thanks
    J

  11. CAIN
    Member
    Posted 8 years ago #

    ATTN: taryn_ & MAK

    I followed everything just as you guys have stated. Upgrading to 2.0.1 didn't magically fix my permalink issue. I even started from scratch again just exactly as you stated taryn_.

    I did and entire dump of mySQL database, and did a fresh install of WordPress 2.0.1. Did everything by the book. No luck getting permalinks to behave correctly. I do have .htaccess working correctly on UNIX-based operating system on Apache web servers. Currently running Apache 1.3.33 on Redhat Linux 7.3 and 9.0 servers. I am completely clueless as to how anyone REALLY gets permalinks to work correctly. I'm ready to give up on the whole idea and just go with the "ugly" links cause that works as it should. The only other method that does work is by including index.php before permalink structure resulting in that "long" custom permalink structure i.e. website.com/index.php/archives/yada/yada/yada

    I spent 19 hours straight yesterday reading these support forms in subjects marked .htaccess, permalinks, mod_rewrite and everything in the Codex of WordPress. NOT ONE person has it spelled it out thoroughly for anyone else to follow. It seems everyone who has got it to work, just says: "great, works for me" and they're outta here. Frustrating to say the least. I was ramped on caffeine all day long yesterday reading, troubleshooting, testing and retesting I must have followed every single example that applied to my permalink situation. Nothing worked. The reason I posted on this thread is because MAK's first post at the top is identical to my situation. To save everyone from hearing it again by making a new thread explaining exactly what MAK has already said, I've posted in this thread.

    I want someone to post exactly the method they've used to make it work. PLEEEEEAAASE!

    I went to bed last night with a hurting brain (probably the amount of caffeine, LOL!) but I tossed and turned thinking about this permalink issue. I have an entirely fresh database so if I have to delete everything over again that's NO problem. I would like thorough instructions as to how to get permalinks to work correctly. My situation is IDENTICAL to this threads first post by MAK. I DO have .htaccess working correctly on UNIX-based operating system on Apache web servers running Apache 1.3.33 on Redhat Linux 7.3 and 9.0 servers. Will someone PLEASE help out on this. This thread is Identical to my permalink issues. What am I doing wrong?

    Thanks in advance.

    ~ CAIN

    P.S. If someone helps me out with this and it works, I promise to re-document Step by Step the method that makes it work, as that is severely missing from the documentation and the support forms.

  12. CAIN
    Member
    Posted 8 years ago #

    DISREGARD MY PREVIOUS POST! ^^^

    I figured it out. My host (fatcow) Does NOT support mod_rewrite. Those BASTARDS!!!

    I am in the process of dumping them and signing up with a recommended host. Wheeew, I thought I was going crazy there for awhile. After writing the string <?php phpinfo(); ?> and saving it as info.php and uploading it into my root directory, viewing it in my browser, It was as plain as day. No supported modules! I then immediately called fatcow and they confirmed their lack of support and incompetence. Thus, I have decided to move away from them and their lack of support. After I sign up with a new host and create a new data base and run through all the process over again I will document it in a new thread on support forms in step by step manner. Hopefully it will shed some new light on this HUGE problem we've all had with permalinks.

    O.K. time to drink some caffeine.

    ~ CAIN

  13. carnold
    Member
    Posted 8 years ago #

    I too am having the exact same problems. I have my blog at http://www.mytimewithgod.net
    I have the mod_rewrite module loaded in Apache (phpinfo file at /phpinfo.php)
    I am using WP 2.0.1 (WP is supposed to do everything for me)
    I start with the default permalink structure (ugly links) -- EVERYTHING WORKS FINE!!!
    Everytime I try to update my permalink structure via the Admin Panel of WP it writes the following info to my .htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php
    </IfModule>

    # END WordPress
    I have confirmed from another user that they too have the whitespace at the end of their htaccess file and it IS working for them.
    I have tried the following suggestions from the WP Codex:

    From Codex:
    1. If you leave whitespace at the end of your .htaccess file, it may make all pages on your site unavailable -- So I removed all whitespace. (Everytime WP updates the file it always adds whitespace, so I make sure to remove it.)

    2. I edited my wp-includes/vars.php file to say -- $is_apache = 1

    3. I edited my httpd.config file to say:
    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory>

    4. I deleted the contents of my .htaccess file and re-created it (by updating the permalink structure).

    NONE of those up above helped me.

    I have tried the following suggestions from other users:

    1. I blanked out the .htaccess file (if I delete it WP doesn't create a new one; WP didn't even create one on fresh install I had to make it myself)
    2. I went to the permalink page in Admin Panel of WP and chose Date and Name based. That is supposed to give me the structure /%year%/%monthnum%/%day%/%postname%/.
    3. After doing that I check my .htaccess file again. My text editor tells me the file was updated by WP so I know it is being written to. When I look at the contents of the .htaccess file it just rewrites the same info I had before: (in otherwords nothing changed)
    You always get 404 errors with permalinks. Can anyone help?

  14. CAIN
    Member
    Posted 8 years ago #

    Carnold ~

    I have spent more than 19 hours trying to figure this one out. You're not alone. I am currently waiting for my DNS to propagate to my new host (mediatemple, same one Michael Heilemann uses), so when that's done I will try from the beginning (again) and document my experience here. I'm keeping my fingers crossed on this one. I would really like to use permalinks the way they're supposed to work. I figure if I get on to the same hosting platform as some of the other users that are using permalinks, maybe I'll get it to work too. I will be making an entirely fresh install of WordPress 2.0.1 so I hope it works. Regardless check back within the next 48 hours, cause I will address this issue with my new experience, Step-By-Step. Thanks for being patient.

    ~ CAIN

  15. RaulTBC
    Member
    Posted 8 years ago #

    Anyone know a resolution for IIS/WindowsServer? I do not have a .htaccess file (and don't know if it will even work on this server configuration). I only have the default permalink working - all others (Date/name, number) both give me the 404 Error page.

  16. vkaryl
    Member
    Posted 8 years ago #

    Carnold: the structure you are seeing in the .htaccess file is exactly the way it is supposed to be. WP handles the permalink stuff internally now, you will never see anything other than this in the .htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php
    </IfModule>

    # END WordPress

    And as a point of reference, I have
    /%year%/%monthnum%/%day%/%postname%/ permalinks working just fine on the 4 installs of 2.0 and 2 of 2.0.1 I have currently as well as on every 1.5 install I still have (um - not sure how many that is, lost count.... 10 or so? maybe).

    This is also working on my local versions of all my installs, using XAMPP under windows XPPro SP1.

  17. carnold
    Member
    Posted 8 years ago #

    Great. I wonder why i can not get permalinks working?

  18. vkaryl
    Member
    Posted 8 years ago #

    I don't know. Since I haven't done one thing anywhere other than install, upload or create an .htaccess file, set it to 777 (online only, doesn't need repermitted under local XAMPP), select the permalink setup as above, update permalinks, then set the .htaccess file back to 644, I just don't know what to tell you.

    [I should probably point out I'm the ONLY PERSON IN THE WORLD who never has bugs in games or other software....]

  19. flyfisher842
    Member
    Posted 8 years ago #

    2/19
    to RaulTBC RE:IIs servers. .htaccess does not apply to them. Unless you are running your own server with administrator priviledges, you will have to have the tech support staff set these permissions at the wwwroot folder. read, write, modify and execute permissions.

    If the wwwroot folder has these permissions, any subfolder will also have them. At the least ask them to set the permissions on the wordpress folder.

    After they did this for me, my archieves links worked ok, the wp-db backup plugin worked and the default permalinks started working. But I can not get the other permalink choices to work. But I am not unhappy with the default structure.

    Flyfisher842

  20. CAIN
    Member
    Posted 8 years ago #

    How I got permalinks to work.

    Step 1. Got rid of my old hosting company (Fatcow.com)

    Step 2. Signed up with a reliable host (MediaTemple.net) recommended by Michael Heilemann (BinaryBonsai.com)

    Step 3. Created a MySQL database at my new host.

    Step 4. Uploaded an entirely fresh install of WordPress 2.0.1 with wp-config.php adjusted to my new hosting environment.

    Step 5. Uploaded .htaccess file, changed chmod to 666.

    Step 6. Ran the wp-admin/install.php

    Step 7. Login > went to Options > Turned on permalinks at wp-admin/options-permalink.php

    Step 8. Went back to .htaccess and turned chmod to 644.

    Totally worked just like it's supposed to. I had NO problems at all. Amazing, just amazing. Painless as could be. The moral of my experience is: "Make sure you're hosting your WordPress site in a reliable hosting environment". I couldn't be more pleased with my new host. It was so easy, I was shocked. After a DAY of massive frustration and lost sleep over my permalinks issue at previous host, it was like a huge weight lifted from my conscience. WordPress functioned exactly as it should in new hosting environment.

    Huge thanks to Michael Heilemann for the recommendation.

  21. nathan
    Member
    Posted 8 years ago #

    I have exactly the same problem with a fresh install on my local (XP) machine, I installed once and re-istalled twice still no joy.

    Permalinks work in default and with index.php/ but nothing else works.

    Apart from re-installing for a forth time and spending hours looking at config files I don't understand is there anything I should check for (I've checked everything four times but I may have missed something)?

  22. intricateartist
    Member
    Posted 8 years ago #

    Bizland is hosting an account I'm trying to setup, and I've had the exact same issues detailed out by MAK, used the same processes to try to correct it with no luck. They say that they allow mod_rewrite, but permalinks are not working at all. Finally got someone with Bizland to look at the htaccess and they added this line:

    RewriteRule ^(.+)$ /index.php/$1 [R=301,NS,QSA]

    And said that it worked now - but it doesn't work in every instance, just for the one problem (paging) that I gave them as an example. I have had NO luck getting any assistance with this - and would love it if someone would offer up some detailed assistance with this so that all the user needed to do is add one line of code to get things functioning. There seem to be a lot of cries for help over this topic and no definitive answers.

    How can it be this complicated?

    Here's my initial cry for help: http://wordpress.org/support/topic/64634?replies=8#post-343466

    I've upgraded, reinstalled, changed permissions, deleted, recreated, and taken my fair share of headache medicine in the process.

  23. moshu
    Member
    Posted 8 years ago #

  24. intricateartist
    Member
    Posted 8 years ago #

    vikingwolf.com

    (See my initial cry for help)

  25. mrsticks
    Member
    Posted 8 years ago #

    I was having the same problem as the OP and most of you, if I read everything correctly. I was taken back at how many people had the same problem. In my case, I fixed mine quite simply. In my WP Admin, I went to Options->General and erased what I had in the Blog Address box. Then I made the permalinks the date/time format and it just worked. I havent looked at my .htaccess, but I assume it is the same one it was creating before, which is the same one the OP had. In the end, WP just copied the WordPress Address to the Blog Address box.
    My issue is resolved and that is how i did it. Ive got the most recent version of WP, downloaded day before yesterday, v 2.0.2

  26. tela
    Member
    Posted 8 years ago #

    I was having the same problem too and that how I fixed it.

    Apache doesn't recommend to use the .htaccess files anymore as they pose some security risks and are slow anyway.

    In httpd.conf:


    # Normally, you already have a very restrictive set of features for all directories
    # that Apache has access to.
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>

    Now you can ask your webhost to add this, considering that
    all WordPress sites are located under this directory
    structure: /var/www/*/wordpress:
    (your main index.php being in /var/www/*/wordpress)


    # This is needed for permalinks to work
    # on WordPress without using .htaccess files
    <Directory /var/www/*/wordpress>
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    </Directory>

  27. DerPolarist
    Member
    Posted 7 years ago #

    I had the same problem as many of you did or maybe still have. I've got another answer which might solve the problem for some of you:
    Even if phpinfo says that mod_rewrite is compiled and activated it does not mean that you have the right to apply rewrite directives. That's what my problem was.
    To figure out if the problem applies to you in this way just create a .htaccess file containing only the directive
    RewriteEngine On
    If you already now get 403: Forbidden Error Messages you don't have the right to use rewrite directives.
    Ask your webspace provider to change the rights for you.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.