WordPress.org

Ready to get started?Download WordPress

Forums

Unique .htaccess/pretty permalink Q (3 posts)

  1. dllorens
    Member
    Posted 6 years ago #

    .htaccess is in the appropriate root directory. This is verified because when I delete it I get the "If your .htaccess file were writable, we...." and when I re-create it and chmod 666 it, wordpress thinks it's writable again.

    Here's the thing though.... WordPress isn't writing to it upon clicking "Update Permalink Structure"

    So if I edit it myself, and add the requisite:
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Still no worky.

    Furthermore, I edited my Apache2's conf.d file to AllowOverride All in both spots, and the restarted the Apache2 server.

    WHAT AM I MISSING?!?!?!?!?!?!?!? I'm going crazy reading the support, there seems to be nothing else.

    I even forced Apache = 1 int the Vars.php page. Apache2 seems to have the mod_rewrite module, or at least /usr/lib/apache2/modules/mod_rewrite.so exists..... I even copied it to the mods-enabled directory even though I know that is useless

    HELP! PLEASE!

  2. dllorens
    Member
    Posted 6 years ago #

    Oh hell yah. Fixed. I'm dumb so I figured it would be called mod-rewrite.so not just rewrite.so. I copied it from /etc/apache2/mods-available to /etc/apache2/mods-enabled and restarted the apache server (/etc/init.d/apache2 restart)

    bang! WORK-O!!!

  3. dllorens
    Member
    Posted 6 years ago #

    now if someone would just be so kind as to help with this thread, as I can't figure this one out myself:


    http://mu.wordpress.org/forums/topic.php?id=6108&page&replies=1#post-36417

Topic Closed

This topic has been closed to new replies.

About this Topic