WordPress.org

Ready to get started?Download WordPress

Forums

SEO Auto Linker
[resolved] Unicode characters on word limits (8 posts)

  1. czcsabi
    Member
    Posted 1 year ago #

    Hi,

    I saw that this came up in the forum couple of months ago. I can reconfirm that words with unicode characters on their ends are still not being linked. My site is utf-8 encoded in Hungarian. If I type "Plútó" as a keyword, then it will be linked only if it has some suffix attached like "Plútói".
    I would be curious if is there a possible fix for this?

    Best Regards,
    Csaba

    http://wordpress.org/extend/plugins/seo-auto-linker/

  2. chrisguitarguy
    Member
    Plugin Author

    Posted 1 year ago #

    Alright, I need you to test something for me.

    In the SEO auto linker plugin folder, replace the front.php file with this https://gist.github.com/5841e38cb2a00baed0f6

    Alternatively, you can use this link to just get the file: https://raw.github.com/gist/5841e38cb2a00baed0f6/e1cb9cba5508d9bd0460748360fe03f38b40d2f9/front.php

    Let me know if that fixes the issue.

  3. czcsabi
    Member
    Posted 1 year ago #

    Its much better now. "Plútó" gets linked, but if its not a precise match then it`s not working. The one with the suffix "Plútói" is overlooked now. Altough this suits my particular needs perfectly. Thank you.

  4. chrisguitarguy
    Member
    Plugin Author

    Posted 1 year ago #

    Okay, that's expected behavior. The plugin won't know that Plútói and Plútó are related -- you'll have to add both to the keywords field of the link.

    SO! The downside of this is that what I did will not be enabled by default, but I'll push some changes to the plugin and release a new version later this week or early next and post the way that you can enabled them. Sound like a plan?

  5. czcsabi
    Member
    Posted 1 year ago #

    that would be great. I dont know, but probably it would benefit many people with foreign language pages if you could make a checkbox at the options page for enabling/disabling unicode support at word limits. This way the users wouldnt have to dabble in the source files. Just an opinion.

  6. chrisguitarguy
    Member
    Plugin Author

    Posted 1 year ago #

    I agree. There's no an option on the admin page to enable them!

    Screenshot: http://wordpress.org/extend/plugins/seo-auto-linker/screenshots/

    There's a new version with this added. Test it out, let me know!

  7. czcsabi
    Member
    Posted 1 year ago #

    I tested with the new option enabled and disabled and is working as expected. When it is enabled it has the same new behavior as with the front.php file you sent me earlier.
    Thank you very much for your work.

  8. chrisguitarguy
    Member
    Plugin Author

    Posted 1 year ago #

    Awesome. Thanks for much for testing it for me!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.