WordPress.org

Ready to get started?Download WordPress

Forums

Facebook Page Publish 2
Unexpected Error #1500 (17 posts)

  1. ixodie
    Member
    Posted 1 year ago #

    This script throws the same error as the original script, noted here:

    http://wordpress.org/support/topic/facebook-returned-an-unexpected-error-1500-the-url-you-supplied-is-invalid?replies=32

    Does anyone have a recommendation for how to resolve this?

    Thanks!

    http://wordpress.org/extend/plugins/facebook-page-publish-2/

  2. cadfile
    Member
    Posted 1 year ago #

    Does anyone have a solution for this? I tried a couple of the suggestions posted such as adjusting the settings of the app and that didn't work.

    Someone posted a homemade patch but I have no idea what it does because the poster didn't explain it

    Are all the page posting plugins broken?

    Where is the author of this plugin?

    Anyone Anyone...

    I need to change if I can't use this to post scheduled posts.

  3. Nathan
    Member
    Posted 1 year ago #

    When I schedule a post or even just post instantly to Facebook I get the following error.

    Your Facebook Page Publish plugin reports an error. Please check your plugin settings.

    While publishing "[post name removed for privacy]" to Facebook, an error occured:

    Facebook returned an unexpected error: (#1500) The url you supplied is invalid
    Try to resolve this issue, update the plugin or inform the author about the problem.
    [Error occured at line 350]

    Below is the code from lines 348 - 351

    http://pastebin.com/RX8X5mEa

    If I go back to the post and click publish again it goes through... this is problematic because I wish to use Schedule to Post and I can't if the plugin errors on the first publish, I would have to go back in to the post and click update (with the checkbox to publish to facebook) checked to have it work.

    I have removed both the plugin and the Facebook App and re-added both. I am still receiving the above error(s).

    /wordpress/wp-content/plugins/facebook-page-publish-2/diagnosis.php
    Reports that Everything looks fine in both areas.

    Please help, I would hate to drop support for this wonderful plugin.

  4. cadfile
    Member
    Posted 1 year ago #

    As far as I can tell from the information I can find this error is completely on Facebook's end. They broke something.

    When I wrote my post all my scheduled posts were failing with the 1500 error but later it started to work again.

    I also made sure my OG tags were perfect by running a url through the debugger and I did have an issue with a post which might have tripped the failure. I had too many duplicate OG tags. I could be that Facebook wants a stream post to be perfect code wise.

    https://developers.facebook.com/tools/debug

    My concern is the author of this plugin hasn't chimed in at all since these error posts showed up. Even if it is something they can't fix which I believe is the case they should at least post here and say that officially.

  5. Nathan
    Member
    Posted 1 year ago #

    Thank you cadfile,

    Your suggestion has solved the plugin issue in my situation. :) You have a wonderful day!

    As far as I can tell from the information I can find this error is completely on Facebook's end. They broke something.

    When I wrote my post all my scheduled posts were failing with the 1500 error but later it started to work again.

    I also made sure my OG tags were perfect by running a url through the debugger and I did have an issue with a post which might have tripped the failure. I had too many duplicate OG tags. I could be that Facebook wants a stream post to be perfect code wise.

    https://developers.facebook.com/tools/debug

    My concern is the author of this plugin hasn't chimed in at all since these error posts showed up. Even if it is something they can't fix which I believe is the case they should at least post here and say that officially.

  6. Jose-Rafael Clemente
    Member
    Posted 1 year ago #

    About Posting to Facebook...

    Facebook returned an unexpected error: (#1500) The url you supplied is invalid
    Try to resolve this issue, update the plugin or inform the author about the problem.
    [Error occured at line 350]
    ---------------------------
    Please do not try anything else, the plugin is running fine. The problem is not with the plugin at all or Facebook App. It is Facebook that made some changes and every other plugin out there are having the same problem.
    Do not change the settings of your App. Just wait for an update...

    Thanks,

  7. FREIGHTDUDE
    Member
    Posted 1 year ago #

    If it was running fine, the posts would show up on facebook and they are not. I am trying to see what is fine about this not posting?

  8. Jose-Rafael Clemente
    Member
    Posted 1 year ago #

    The plugin is running fine...The problem is not the plugin, in fact they are working on getting an update as soon as possible. It is Facebook that is blocking everyone..

    Also keep in mind that I'm not the developer of the plugin, I'm another user just like you.

    I currently have 4 different plugins trying to do the same and none of them are working due to Facebook blocking all plugins from automatic posting.

    Thanks,

  9. ktrusak
    Member
    Posted 1 year ago #

    Hi, I ran into the same issue, can anyone else confirm it is still going on?

  10. FREIGHTDUDE
    Member
    Posted 1 year ago #

    I fixed it. Are you using Yoast SEO by chance?

  11. ktrusak
    Member
    Posted 1 year ago #

    I am in fact, I'm guessing that isn't a coincidence

    Thank you for the quick reply

  12. FREIGHTDUDE
    Member
    Posted 1 year ago #

    go to your facebook account and once logged in enter your URL here: https://developers.facebook.com/tools/debug It will tell you why it is not posting.

    mine was og:image and od:author that was incorrect so I saw that you could turn that off in Yoast SEO. Worked fine after that http://www.freightbybus.com is the site I fixed it on.

  13. FREIGHTDUDE
    Member
    Posted 1 year ago #

    once you see why it is not working you can check the box on this page (change the xxxxx to your URL) http://xxxxx.com/wp-admin/admin.php?page=wpseo_titles&settings-updated=true#top#post_types

    Check the boxes that say WordPress SEO Meta Box and save

  14. ktrusak
    Member
    Posted 1 year ago #

    You're the best, thank you that worked perfectly

  15. FREIGHTDUDE
    Member
    Posted 1 year ago #

    Glad I could help. Now if you ever need shipping, let me know! lol

  16. ktrusak
    Member
    Posted 1 year ago #

    hahaha will do.

  17. bakbak
    Member
    Posted 10 months ago #

    I get this error when submitting a post...

    Warning: json_decode() expects parameter 1 to be string, array given in /home2/name/public_html/example.com/wp-content/plugins/facebook-page-publish/fpp_index.php on line 648

    any ideas?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.