WordPress.org

Ready to get started?Download WordPress

Forums

Unclosed CDATA Section... grr (3 posts)

  1. o2b
    Member
    Posted 8 years ago #

    I've had this problem in the past, but I've always found a culprit. I thought I recalled finding a solution in the forums in the past, but I can't today.

    My feed (http://o2b.net/feed/) has an unclosed CDATA section. I know it has to do with the most recent post, but I've picked it apart for an hour, I can't find what specifically is causing the problem.

    This happens on a frustratingly regular basis.

    Any thoughts?

  2. Tim Griffin
    Member
    Posted 8 years ago #

    I discovered the same on my site today.
    Something between the 10th and 20th post was unclosed. How do I fix this problem? I went and changed the display to only serve out the last 10 posts and now the culprit is gone. But if I turn it back to disply 20 posts in the rss we are back to the <Unclosed CDATA> error.

    I am using 1.5.2
    :-)

    P.S. the search this site option has not worked for me since the release of 2.0 came out! I have to go to google and do a site search from there.

  3. norbit
    Member
    Posted 8 years ago #

    http://wordpress.org/support/topic/77660

    I found this issue that changes the closing cdata to ]]> I have no idea why they do this in WP...

    You might want to try commenting the line in the function in wp-includes/template-functions-post.php file line 57 -

    // $content = str_replace(']]>', ']]>', $content);

    That might fix your problem...

    Why this exists in there i dont know as 'if' you wantted that kind of function it should be applied as a content filter!

Topic Closed

This topic has been closed to new replies.

About this Topic