WordPress.org

Ready to get started?Download WordPress

Forums

WP-TopBar
[resolved] Uncaught Type Error: Property '1' of object # is not a function (8 posts)

  1. joelkarunungan
    Member
    Posted 10 months ago #

    JS error from the plugin. See the site at http://current.webutation.com/

    This happens when the Close button settings are set to allow topbar to be closed by the user, reopened, start open, and use cookies.

    The topbar is also not showing up. I think it may be because of the JS error, or a bad CSS rule for the div with id wptbheadline1 which is set to display:none.

    Can you provide a patch so I can fix it on our site or provide the fix in a new release of the plugin? Thank you.

    http://wordpress.org/plugins/wp-topbar/

  2. Bob
    Member
    Plugin Author

    Posted 10 months ago #

    For some reason, the javascript that is being generated is missing the code that selects the TopBar. Can you export your TopBar (in JSON FORMAT) and email it to me? My email address is in wp-topbar.php.

    I can then load your TopBar on my test site and quickly debug the issue.

  3. joelkarunungan
    Member
    Posted 10 months ago #

    I've sent it to your email address. Thanks man for looking into this.

  4. Bob
    Member
    Plugin Author

    Posted 10 months ago #

    I was able to recreate the error with your file... Now I have to find the defect.

  5. Bob
    Member
    Plugin Author

    Posted 10 months ago #

    In wp-topbar.php

    Look for this line:

    function wptb_build_reopenable__topbar_js ($wptbTopBarNumber) {

    Replace it with this line

    function wptb_build_reopenable__topbar_js ($wptbOptions, $wptbTopBarNumber) {

    Let me know if that works for you,

    Bob

  6. joelkarunungan
    Member
    Posted 10 months ago #

    Unfortunately, it caused a regression. The bar now appears but when the close button is clicked, it causes the bar to close then reopen by itself. When it automatically reopens, the bar is empty.

  7. Bob
    Member
    Plugin Author

    Posted 10 months ago #

    The TopBar on your site is working perfectly for me on Chrome.

    http://current.webutation.com/

    What browser are you using?

    Bob

  8. joelkarunungan
    Member
    Posted 10 months ago #

    That's not topbar anymore. We removed the plugin.

Reply

You must log in to post.

About this Plugin

About this Topic