WordPress.org

Ready to get started?Download WordPress

Forums

Unable to upload images (tried other posts) (6 posts)

  1. invertigofreak
    Member
    Posted 6 years ago #

    Hi all... I am trying to upload some images onto my site through wordpress and am having no luck, I have tried a few things (including things found in other posts on here)

    * I have tried uploading through the normal way when you are posting photos. No luck. It gives me The uploaded file exceeds the upload_max_filesize directive in php.ini.

    * I have tried uploading through nextgen gallery - it just says 0 images added.

    * Tried deactivating nextgen gallery. no luck.

    * Went through and deleted the files I had to give me 15mb upload rather than 2mb. No luck.

    * Tested it on another site, on the same server, using the same version of wordpress... It worked there.

    The file is only 450kb so there shouldn't be a problem with the size (and have checked phpinfo.php and it says the upload is 2MB)

    I have tried changing permissions of folders as suggested by someone else in one of the other posts, but no luck.

    I hope someone can tell me what the problem is, it has me stumped!

  2. stevenmedleycom
    Member
    Posted 6 years ago #

    change your php.ini to allow up to 32mb see if that helps, i know i seen something about that before.

  3. meganano
    Member
    Posted 6 years ago #

    Can someone explain how to change the php.ini file? Is it part of the wordpress package or something I should be able to find somewhere else on the server? I've been hunting around, but to no avail. I find explanations like this totally frustrating. After all... the error message makes it obvious that you might want to change that file/setting/whatever. I come to the support forums to find out how. Instead there are eight topics on the same error message with no explanation of what the php.ini file even is and how it affects wordpress users.

  4. Alex Rabe
    Member
    Posted 6 years ago #

    Php.ini is part of php, and it's location is often very different based on the installation. Try to ask your web hoster, they should know them...

  5. wkessel
    Member
    Posted 6 years ago #

    Even changing the PHP.ini file doesn't work: at my office, we changed the PHP.ini file to allow 16MB files in response to this.

    Now, when you try to upload anything larger than 1MB, it tells you that "This file is too big. Your php.ini upload_max_filesize is 16MB."

    Upgraded to 2.5.1 in the hopes that this would go away. Fat chance. Tried the .htaccess fix, deleting the js_cache, deleting cookies and the browser cache, switching browsers, switching operating systems (from Win to Mac) -- still no dice.

    I'm beginning to wonder what the security settings are on the WP testing servers: if they're lax, then increased security (which is something not many people will be able to do anything about) could bork the whole mess...

  6. WhisperT
    Member
    Posted 6 years ago #

    Have ANY of you tried making sure your using PHP5?

    I have found that many people running on different hosts just needed to make sure they were using PHP5.

    If you do not know what version of PHP is running on your host you should try creating a PHP Info file and then accessing it in your browser. This will also give you other helpful information about your server setup.

    If your site is not running on PHP5 (you've probably been laden with troubles on other plugins too) you should contact your hosting company and urge them to upgrade.

    @meganano // you do not necessarily need to edit your php.ini file you probably just need to add one to the directory it is needed in. Google is always the best tool when your not sure what something is. You can find a list of directives and how to use them here, but in many cases this may be somthing you have to work out with your hosting provider. Since ini really is a server specific thing it would difficult for Alex to go through and research and explain how each and every person needs to handle their ini problems.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.