WordPress.org

Ready to get started?Download WordPress

Forums

Unable to upload images through wordpress server (13 posts)

  1. vijithreddy
    Member
    Posted 1 year ago #

    When I try to upload to any image onto the wordpress site. This is the error I am getting
    The uploaded file could not be moved to [path]

  2. michael.mariart
    Member
    Posted 1 year ago #

    Most times this means that the permissions on the folder that the image is being stored in are not set to allow files to be added. You can read more about file permissions at http://codex.wordpress.org/Changing_File_Permissions

  3. vijithreddy
    Member
    Posted 1 year ago #

    I have now set the permissions to CHMOD 777 on my every folder but this is the error I am getting.
    Even uploads is 777 and is its subfolders.
    The uploaded file could not be moved to /home/home7/vzb0008/public_html/wordpress/wp-content/uploads/2012/11.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    And the rest of the error message?

  5. vijithreddy
    Member
    Posted 1 year ago #

    Thats the only error message I am getting. That I cant upload a file to that directory. By default my server is setting a folder to 755 and I am manually changing it to 777. Even though I do that it is unable to upload the file.

  6. vijithreddy
    Member
    Posted 1 year ago #

    Thats the only error message I am getting. That I cant upload a file to that directory. By default my server is setting a folder to 755 and I am manually changing it to 777. Even though I do that it is unable to upload the file.

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    There's usually a second part to the error message. Did you create the /uploads folder manually?

  8. vijithreddy
    Member
    Posted 1 year ago #

    Yes, I had to create it manually else it was giving me The uploaded file could not be moved to [path]error. The same error that I got before changing the permissions. On filezilla it shows that all my directories are in 777. This is what I did CHMOD -v -R 777 wordpress.

  9. esmi
    Forum Moderator
    Posted 1 year ago #

    Delete that folder. On many servers, it is imperative that WordPress created the uploads folder itself.

  10. vijithreddy
    Member
    Posted 1 year ago #

    I did. Now I am getting Unable to create directory wp-content/uploads/2012/11. Is its parent directory writable by the server? error.

  11. esmi
    Forum Moderator
    Posted 1 year ago #

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

  12. vijithreddy
    Member
    Posted 1 year ago #

    My wp-content is 777. That is the writable and executable by all.

  13. esmi
    Forum Moderator
    Posted 1 year ago #

    OK - you need to contact your hosts. It sounds like you have a folder ownership issue that needs to be resolved at the hosts' level.

Topic Closed

This topic has been closed to new replies.

About this Topic