WordPress.org

Ready to get started?Download WordPress

Forums

Unable to upgrade to 3.3 (5 posts)

  1. zurih
    Member
    Posted 2 years ago #

    Hey
    I'm currently on WP 3.2.1. When I try to perform auto-upgrade from the dashboard, in the end I get a blank page, that the URL is:
    /update-core.php?action=do-core-upgrade&_wpnonce=37a881b05b

    It's hosting in a shared account under a VPS - which I'm the admin.

    Any idea what's the issue? How can I debug it?
    Maybe some miss-configuration in my server that disturbs it somehow?

    Any assistance would be appreciated.
    Thank you

  2. tommycopeland
    Member
    Posted 2 years ago #

    Is your server running php5 or above?

  3. mindwave
    Member
    Posted 2 years ago #

    TOMMYC

    Not to hijack the thread, but how can you tell?

    I'm having an issue with the upgrade, but mine is 2 fold, although I believe one of the issues has to do w/ PHP5.

    I went to my CP and "setup PHP5 and created an SQL DB, but how do I make the association to wordpress?

  4. tommycopeland
    Member
    Posted 2 years ago #

    Well, only your hosting provider can update the PHP version, and most legit providers are up to date. Sometimes I run across servers that are not, and any version of WP past 3.0 needs the server to support PHP5...that's the only reason I asked. You can tell by logging into cPanel and reading the server stats on the left hand side...it should say "PHP version: 5.2.17". If it's anything below PHP 5.0, you'll want to asked your provider to install 5.0 or above.

    Unfortunately, that's the only issue I can think of. Other than that, you should always deactivate all of your plugins before performing an upgrade, and try manually upgrading your WP files using this Codex: http://codex.wordpress.org/Updating_WordPress

  5. mindwave - Check if your host makes you declare PHP5 in your .htaccess.

    ONE of these in there may help:

    AddType x-mapp-php5 .php
    AddHandler application/x-httpd-php5 .php
    AddHandler cgi-php5 .php

    WordPress will (should) error on install if you have PHP 4 as of WP 3.0

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags