WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Unable to upgrade automatically my plugins (7 posts)

  1. cyberanto
    Member
    Posted 4 years ago #

    Hello all,

    I am having trouble upgrading automatically my plugins. I thought it was because I was using an older version of wordpress. But I just updated to 2.8.6 and it is still not working.

    For instance, if I want to upgrade the Akismet plugin, I get a new page with:

    Downloading update from http://downloads.wordpress.org/plugin/akismet.zip.
    Unpacking the update.

    And then nothing happens.

    Can someone help me? My blog is based on http://www.cyberanto.com

  2. MichaelH
    Member
    Posted 4 years ago #

    First try deactivating plugins then try again.

    If not, then consider increasing the amount of memory allocated to PHP.

    If not that, then you may need to loosen file permissions (see Changing File Permissions)

    --------------------
    Methods for increasing the amount of memory a PHP script may consume

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)

    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M

    3. Try adding this line to your wp-config.php file:
    define('WP_MEMORY_LIMIT', '64M');

    4. Talk to your host.

  3. cyberanto
    Member
    Posted 4 years ago #

    Thank you MichealH,

    But where can I find the PHP.ini and .htaccess files?

    If I can't find them at all, can I just add define('WP_MEMORY_LIMIT', '64M'); to the wp-config.php file?

    Thanks.

  4. MichaelH
    Member
    Posted 4 years ago #

    You may not have access to PHP.ini so you would need to talk to your host if you do want changes.

    If you have a Windows server then .htaccess won't be there. Consider getting a Linux hosting solution.

    You can add that to wp-config.php as explained in Method 3 above.

    This plugin is sometimes helpful in seeing what transit method your hosting used for upgrade: http://wordpress.org/extend/plugins/core-control/

  5. cyberanto
    Member
    Posted 4 years ago #

    I have created a text file named "PHP.ini" in which I wrote:

    memory_limit = 64M ;

    I uploaded that file in the wp-admin folder, and now it seems to be working fine. I was able to automatically upgrade all of my plugins except GD Star Rating.

  6. ma7aba star
    Member
    Posted 4 years ago #

    try Disable it and give ..folder (upgrade)... wp-content/upgrade permission 777

  7. ma7aba star
    Member
    Posted 4 years ago #

    You can also try the following:

    Additions to upgrade plugins

    1. Disable plugins
    2. Change the permissions on the folder upgrade
    Inside track
    wp-content/upgrade .......... To 777
    3. Added upgrade code should be added with

    [PHP]

    / ** Override default file permissions * /
    if (is_admin ()) (
    add_filter ( 'filesystem_method', create_function ( '$ a', 'return "direct";'));
    define ( 'FS_CHMOD_DIR', 0751);
    )

    [/ PHP]
    To the file wp-config.php

Topic Closed

This topic has been closed to new replies.

About this Topic