WordPress.org

Ready to get started?Download WordPress

Forums

Unable to set expiration of cache images greater than 24 hours (3 posts)

  1. vitaminscience
    Member
    Posted 2 years ago #

    Macular-Degeneration-Vitamins.com is installed on WPEngine, and the site uses WPEngine's CDN.

    All load speed testing services (Google PageSpeed, YSlow, WebPageTest.Org) state that images cache are set to expire in 24 hours.

    But my browser cache settings are:

    Set Expires Header: Selected
    Set Cache Control Header: Selected
    Set Entity Tag: Not Selected
    Set W3 Total Cache Header: Selected
    Set Expires Header: Selected

    Media and Other Files Settings:
    Expires Header Lifetime: 31536000 Seconds
    Set Cache Control Header: Selected
    Cache Control Policy: Cache with Validation
    Set Entity Tag: Not Selected
    Set W3 Total Cache Header: Selected

  2. cyonite
    Member
    Posted 2 years ago #

    Do you have the Apache expires module enabled?
    Have you checked your .htaccess file to see if the mod_expires are using correct time A31536000?

  3. Frederick Townes
    Member
    Posted 2 years ago #

    What are the results of the compatibility test on your site?

Topic Closed

This topic has been closed to new replies.

About this Topic