WordPress.org

Ready to get started?Download WordPress

Forums

Booking Calendar
[resolved] Unable to select days in calendar in v4.1 and above (6 posts)

  1. chamblacha
    Member
    Posted 1 year ago #

    I've been using v4.0.1 of the booking calendar without any issue and after upgrading to v4.1, v4.1.1 and v4.1.2 I'm no longer able to select days in the calendar. I've cleared my browser cache, tried different browsers and PC's and it no longer works. I've revert back to v 4.0.1 and the calendar works. I then upgrade back to the latest v4.1.2 and I get the same fault again.

    I've now reverted to v4.0.1 again and evrything works fine. Any idea why this happens?

    Cheers.
    Steven.

    http://wordpress.org/extend/plugins/booking/

  2. wpdevelop
    Member
    Plugin Author

    Posted 1 year ago #

    Hello.
    If you are using only the availability calendar and not the booking form, so then in the version 4.1 the selection of the days is disabling. The reason of this is using the availability calendar only for the showing of the availability (because even in the previous version 4.0.2 the selections of the days in the (only) availability calendar have no any further functionality). This future was requested by different users of plugin.

    But the selection of the days in calendar with booking form have to work in the same way as in the previous version. If its not work, please send the link to your page, and then I will recheck it.

  3. chamblacha
    Member
    Posted 1 year ago #

    Sorry for the delay in responding ... I am using the booking form and the availability calendar together but they stop working when I upgrade to v4.1 or above. I'm guessing it's something to do with jQuery.

    Do I need to update the version of jQuery or will the in built version in WordPress v3.5.1 be ok?

    I would need to upgrade the version of the availabilty booking in my site before you can see this error. Is this something you want me to do?

    Steven.

  4. wpdevelop
    Member
    Plugin Author

    Posted 1 year ago #

    Hello.
    Please recheck your page for the any JavaScript errors (please check more detail here how to check about errors).
    You can check more info at the FAQ in the troubleshooting section.

    Built in jQuery version in WordPress 3.5.1 is fine.

  5. chamblacha
    Member
    Posted 1 year ago #

    I've finally got back to checking this and can confirm it was, in fact, an invalid jQuery version. I've used the WordPress version and all is working fine now.

    Great product. Thanks for your support.
    Steven.

  6. wpdevelop
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, good to know that its works.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic