WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
Unable to run backups (12 posts)

  1. kylen20
    Member
    Posted 5 months ago #

    Hi

    I've just updated to the latest version of the plugin and am unable to run a backup. I keep getting this message:

    Something went wrong with your backup. It looks like another process might already be trying to backup your database. Please try again in a few minutes. If the problem persists please contact support.

    So I'm contacting support. How do I fix this??? Thanks!

    Kyle

    https://wordpress.org/plugins/better-wp-security/

  2. Reh Boot
    Member
    Posted 5 months ago #

    I had the same problem today. Created the directory 'ithemes-security' and it's subdirectory 'backups' (/wp-content/uploads/ithemes-security/backups) manually and set it's permissions to 750.

  3. kylen20
    Member
    Posted 5 months ago #

    Creating the folders manually on the server solved it for me.

  4. robwakeman
    Member
    Posted 4 months ago #

    Thanks Reh Boot. Great advice. That's solved it for me. My backup settings were actually Email only, but there was never an attached database with the email. I guess the database backup was never created.

    Manually creating these folders with suggested permissions now works - the zip attachment arrives.

    Rob

  5. siprof
    Member
    Posted 4 months ago #

    Thanks Reh Boot, your advice works

  6. Agentur Pixelportal
    Member
    Posted 2 months ago #

    Go into your WordPress Backend go to Security - Settings go to Database Backups there you will find the path to your backup folder. Go into the folder wp-content/uploads/
    look for the folder "ithemes-security" and into this folder for "backups" folder if there is no folder create this folders and give it the right permissions 750 for both folders.After this procedure it should be possible to remake a backup! :)

  7. netfusionstudios
    Member
    Posted 1 month ago #

    I tried the above, but I still get the error 'Something went wrong with your backup. It looks like another process might already be trying to backup your database. Please try again in a few minutes. If the problem persists please contact support.'

    I see the folder path is correct and permissions are set to 750. Any other ideas? There are no other backup plugins installed on this site.

  8. Reh Boot
    Member
    Posted 1 month ago #

    Did you try to completely uninstall and then reinstall the plugin?

  9. kaylynnej
    Member
    Posted 1 month ago #

    Hi,

    I am also getting the error message:

    "Something went wrong with your backup. It looks like another process might already be trying to backup your database. Please try again in a few minutes. If the problem persists please contact support."

    I tried the above solution (creating the path manually for the backups and setting the permissions to 750) but it doesn't work. I have also tried to erase the log files since that's what caused the error on another one of my sites.

    Any idea on how to solve the problem??

  10. kaylynnej
    Member
    Posted 1 month ago #

    I also tried to uninstall and reinstall the plugin, but it doesn't work.

  11. netfusionstudios
    Member
    Posted 1 month ago #

    I did the uninstall and still nothing. Pretty sad. I want to spend $250 on their suite, but they have no interest in proving to me the product works.

  12. paazmaya
    Member
    Posted 1 month ago #

    I had the same issue and while I had changed the backup location setting to another location, I received the same message as the initial comment on this topic.
    I also has "locally and email".

    Only after creating the "/wp-content/uploads/ithemes-security/backups" folder with proper writing access, the backups were emailed.

    Strange that the given location is used, even when the setting differs.

Reply

You must log in to post.

About this Plugin

About this Topic