WordPress.org

Ready to get started?Download WordPress

Forums

WEBphysiology Portfolio
[resolved] Unable to retrieve thumbnail from ShrinkTheWeb.com (5 posts)

  1. pattyland
    Member
    Posted 1 year ago #

    Hi,

    I just installed your plugin and try to use STW to generate my thumbnails, but I keep getting the error "Unable to retrieve thumbnail from ShrinkTheWeb.com"

    The answer from stw is "invalid credentials", although I print out $request_url from stw.php and tried in my browser, where it works fine...

    Any idea what's going wrong?

    Greets, pattyland

    http://wordpress.org/extend/plugins/webphysiology-portfolio/

  2. Jeff
    Member
    Plugin Author

    Posted 1 year ago #

    Did you enter the STW Access Key and Secret Key into the Portfolio Options? Mine's working fine.

    Cheers,

    Jeff

  3. pattyland
    Member
    Posted 1 year ago #

    Hi Jeff,

    yes! I found the problem.

    In line 234 in stw.php you use http_build_query without any parameter. The default arg_separator on my server seems to be "&amp ;" (the space is only because the forum translates it otherwise ;) ) , which leads to a broken request to stw!

    I changed the line to:
    $request_url = "http://images.shrinktheweb.com/xino.php?".http_build_query($args, '', '&');
    which fix my problem.

    Greets, pattyland

  4. Jeff
    Member
    Plugin Author

    Posted 1 year ago #

    Pattyland,

    Glad you got it working. I'll take a look at this code but no one else has noted a problem. Sounds like I might need an option to set it for these rare cases, eh?

    Glad you figured it out and thanks for sharing what you found.

    Jeff

  5. pattyland
    Member
    Posted 1 year ago #

    I don't think that there is need for an option, just set this parameter always to "&", in case the default parameter is something else ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.