WordPress.org

Ready to get started?Download WordPress

Forums

Unable to restore site after changing URL (16 posts)

  1. dustinjw
    Member
    Posted 5 months ago #

    Hello;

    So after a misunderstanding, I made the lethal error of changing a WordPress site's URL in the general settings of the WP admin dashboard.

    Of course, I got the 'site not found' message and am unable to log back into the WP admin. 404 errors all around.

    So, after reading a ton of posts on this forum about restoring the website, I changed the URL back to the original directly in the database, as per these instructions: http://codex.wordpress.org/Changing_The_Site_URL#Changing_the_URL_directly_in_the_database

    But it's still the same problem. Also, the site I created was built on a temporary URL provided by Bluehost. Not sure if that might be complicating things.

    Any help appreciated.

  2. Tara
    Member
    Posted 5 months ago #

    Try clearing all cache.

    Also, try using different browser/computer.

  3. graphical_force
    Member
    Posted 5 months ago #

  4. dustinjw
    Member
    Posted 5 months ago #

    Thanks for the input, still no luck though.

    Would the fact that it's a temporary URL, (for example: : http://69.195.144.178usernamewebsite.com) be causing additional problems?

    Thanks again.

  5. Tara
    Member
    Posted 5 months ago #

    Would the fact that it's a temporary URL

    Please elaborate, give us some more info.

  6. dustinjw
    Member
    Posted 5 months ago #

    OK, here's the backstory: I created a new website for a friend of mine using WordPress. Their old site was using Weebly with a GoDaddy domain.

    They moved the domain over to Bluehost but I created their new WP site on what appears to be a temporary domain provided by Bluehost. Here's what they gave us: http://69.195.124.136/~useraccount/travelingmilemarkers/

    So then I tried to switch the URL in the general settings in WP to just http://www.travelingmilemarkers.com. And that's when the trouble began.

    All input appreciated. Thanks.

  7. Michelle
    Member
    Posted 5 months ago #

    Have you confirmed that http://www.travelingmilemarkers.com is pointed at the new BlueHost IP address? Because it looks like it might still be pointing at Weebly.

  8. kmessinger
    Volunteer Moderator
    Posted 5 months ago #

    http://www.travelingmilemarkers.com/ works fine for me.

    [edit] But there is weebly there.

  9. dustinjw
    Member
    Posted 5 months ago #

    Ah, thanks for pointing that out Michelle. Perhaps that's part of the problem.

    Any idea why I'm not able to access the admin login via http://69.195.124.136/~useraccount/travelingmilemarkers/ though, despite changing the URL in the database? this is the bluehost site.

    Really, I'd like to just get things back to the way they were even if that means going with the http://69.195.124.136/~useraccount/travelingmilemarkers/ URL again.

    And yes, I forgot to mention that http://www.travelingmilemarkers.com/ is the old Weebly website --- all the content has been changed. They don't want to use that anymore.

    Thanks.

  10. Michelle
    Member
    Posted 5 months ago #

    When you go to http://69.195.124.136/~useraccount/travelingmilemarkers/ does it work to show you the new WP site?

    Did you change the URL in phpMyAdmin wp_options to http://69.195.124.136/~useraccount/travelingmilemarkers/ in one place or two? both site_url and wp_url should be set to that (without the trailing slash I think?).

    After you make the change be sure to clear cache in your browser, especially if you're using Chrome. Chrome/Safari are very aggressive about caching.

    After this is all working, then you'd want to go into where ever the domain is registered and change the settings to point the domain at Bluehost. You could either update the DNS/nameservers entirely to use Bluehost's, which would repoint everything (including their email, which would be dangerous if they were all set up for it on GoDaddy!) to Bluehost, or just update the A Record, which would only repoint the website.

  11. dustinjw
    Member
    Posted 5 months ago #

    No, when I go to http://69.195.124.136/~useraccount/travelingmilemarkers/ it doesn't show the new website. It used to until I changed the WP URL settings to travelingmilemarkers.com. Now it's just a 404 error.

    I did change the URL in phpMyAdmin in two places. I pasted the exact method I used at the end of this message.

    And yes, the domain was originally registered with Bluehost. They actually provided us with it: http://69.195.124.136/~useraccount/travelingmilemarkers/

    Thanks for your help, though. If you have any other thoughts I'd love to hear them.

    Changing the URL directly in the database
    If you know how to access phpMyAdmin on your host, then you can edit these values directly to get you up and running again.

    Backup your database and save the copy off-site.
    Login to phpMyAdmin.
    Click the link to your Databases.
    A list of your databases will appear. Choose the one that is your WordPress database.
    All the tables in your database will appear on the screen.
    From the list, look for wp_options. Note: The table prefix of wp_ may be different if you changed it when installing.
    Click on the small icon indicated as Browse.
    A screen will open with a list of the fields within the wp_options table.
    Under the field option_name, scroll down and look for siteurl.
    Click the Edit Field icon which usually is found at the far left at the beginning of the row.
    The Edit Field window will appear.
    In the input box for option_value, carefully change the URL information to the new address.
    Verify this is correct and click Go to save the information.
    You should be returned to your wp_options table.
    Look for the home field in the table and click Edit Field. Note There are several pages of tables inside wp_options. Look for the > symbol to page through them.
    In the input box for option_value, carefully change the URL information to the new address.
    Verify this is correct and click Go to save the information.

  12. Michelle
    Member
    Posted 5 months ago #

    So, in both places in the wp_options table it's now set to http://69.195.124.136/~useraccount/travelingmilemarkers correct? (Note no end slash on that URL either place.)

    About to hop out for some errands but promise to follow up as soon as I can. :)

  13. dustinjw
    Member
    Posted 5 months ago #

    Sorry Michelle, I realized I didn't change the wp_url in wp_options. However, when I went to make that adjustment I noticed that wp_url doesn't appear in any of the pages under wp_options for this database.

    Maybe I'm in the wrong database? The one I'm in is called useraccount_travelling. When I switched the site_url in WP admin I noticed that the change was made in this database(under wp_url), so I assumed I was in the right one. The other databases are:

    useraccount_wor1
    useraccount_wor2
    useraccount_wordpress
    information_schema

    And the friend whose site I'm working on does have another WP website with Bluehost on this account. I really don't want to alter that one by mistake.

    Thanks again for all your help.

  14. dustinjw
    Member
    Posted 5 months ago #

    RE: "When I switched the site_url in WP admin I noticed that the change was made in this database(under wp_url), so I assumed I was in the right one."

    Whoops, I meant 'the change was made in this database (under site_url)". The wp_url doesn't appear, as I mentioned before.

    Thanks,

  15. Michelle
    Member
    Posted 5 months ago #

    Can you Ftp into the correct folder for this domain? If so download a copy of wp-config.php and look in it to confirm which database your site is using.

  16. dustinjw
    Member
    Posted 5 months ago #

    Ok, great. I've just go get their ftp login details and then I'll post how it all went.

    Really appreciate all the help Michelle.

Reply

You must log in to post.

About this Topic

Tags

No tags yet.